2

I installed Drupal 8.5.6, in French. It seemed to work well, apart from no CSS working, but I corrected by unchecking CSS aggregation in the performance settings.

I decided to install some modules, one by one. Every time I install a module, after I click on the Install button, I get this.

screenshot

After waiting more than 2 minutes (which is abnormal to me), I click on the Extend link to see if the module I am trying to install has been installed. The module seems to be installed, since it is checked, but it is not working.

So I uninstall that module, and try installing another module, but I get the same result.

Notice that the first modules I tried installing were the Coffee and Admin Toolbar modules. They get installed properly offline.

I have also noticed that using Drupal 8.2.5 everything is fine.

Is there any version problem, or am I doing something wrong?

I changed the PHP version using on the host to PHP 7.1.

2

After a few time doing something else, I went back to the issue. In fact a lot of JavaScript was not working correctly.

Then I decided to go back to Configuration -> Performance and unchecked JavaScript aggregator and saved that configuration. See the image below :

enter image description here

Now everything works fine!!!

Now I can use admin toolbar's dropdown menu as well as coffee and all the other stuff is working well.

And thank you for reading me.

  • This is only a work around. The cause of the error is that your Drupal installation is not able to create the aggregated CSS/JS files in sites/default/files/. The same happens for the translation files or the image styles in your follow up question drupal.stackexchange.com/questions/267401/no-image-is-showing – 4k4 Aug 12 '18 at 9:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.