I created a new index and I've created a view with it but it only has the options to show as Search Results & Fields. Is there something that has to be done when configuring the index to get Rendered Entity to show up on views?

It does show up with the Default Content Index made with the module but whenever I make a new index and create a view with it isn't an option.

Pictures: What appears when creating a view with the default index(1) vs an index that I created(2).

What appears when creating a view with the default index

What appears when creating a view with an index that I created

  • I think you need to be indexing a field that requires the rendered entity for it to be available, for example the Rendered HTML output field – Clive Aug 12 '18 at 13:34
  • I do have a Rendered HTML output field but it still doesn't give the option. I tried changing a few of the view mode options in the field and tried making it the same as the default but still no luck. – Hali R Aug 12 '18 at 17:01

Just figured it out. I found this. All I needed was to flush all caches.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.