0

I am using CKEditor and WYSIWYG. After updating Drupal core to 8.5.6, I cannot upload an image using the CKEditor's 'image' button anymore saying "Image Field is required."

enter image description here

enter image description here

I have checked CKEditor's plugin settings. Image upload's enabled there.

enter image description here

I have not found a solution yet. Any help will be appreciated.

PS: If I add an image using html "img" tag then it shows up properly, it's only the button that is not working properly.

1

I found a solution. Suggested by Tech-Tonic:

https://www.drupal.org/forum/support/post-installation/2018-08-24/ckeditor-image-button-cannot-insert-images-in-body-of-a#comment-12854570

Does your content type have other file fields on it? If so, try temporarily disabling all file/image fields for the content type in "Manage form display" and save. Then enable them again and save. Worked for me, in Drupal 8.6.3.

As mentioned above, I also had an image/file field in the content type. Under 'Manage form display', I disabled the image field and saved. I then went back to 'Manage form display', moved it back to where it originally was and saved again.

After this the error no longer appears. This worked on the production, staging and development copies of the same site.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.