1

I have Drupal 7.59 installed and CAPTCHA is visible for several forms. I want it visible only for the login form.

In this section: admin/config/people/captcha, I set the 'No Challenge' for other form-ID and login-form set on 'default challenge type' but the CAPTCHA gets displayed on all forms: by this text : "CAPTCHA: NO CHALLENGE ENABLED".

How can I prevent the display of CAPTCHA for other forms except the login form?

  • Is it showing on the forms also, when you are logged out? The Captcha module has an indication mode for administrators, that indicates on all forms, whether Captcha is enabled or not. – Mario Steinitz Aug 25 '18 at 11:47
  • Thanks. ya when I logged out, not showing on the forms. How can I config the indication-mode and disable it? – stare green Aug 26 '18 at 7:35
  • Please check with my answer below. – Mario Steinitz Aug 26 '18 at 12:05
1

The message "CAPTCHA: no challenge enabled" indicates, that the form in question is not protected by a captcha.

This message is shown to site administrators and users with the "Administer CAPTCHA settings" permission only. It is intended to ease administering captchas on the form. You could, e.g. click the message to open a link that allows you to enable a captcha for this form.

If you don't require these administrative links, you can disable them within the captcha module settings. In your administrative back-end navigate to Configuration > People > CAPTCHA.

Locate the option "Add CAPTCHA administration links to forms", uncheck it and save the settings. The administration links should be gone.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.