0

I have a view that lists faculty members in a table. Everything was working fine until I decided to go into incognito mode to view the table. It wasn't rendering anything at all. So I went back and tried a few things:

  1. Since it was a view/display issue, I thought it was caused from the permissions. So I changed all the permissions to access: none (and a bunch of other combinations). This didn't seem to be the issue.

  2. Selecting Bypass content access control worked fine, but I don't want to use this because of the security implications.

  3. Getting rid of the relationships works, but I need the relationships.

Note that this view works if I am logged in as administrator user; it doesn't work when I am in incognito mode (logged out/anonymous user). So I suspect it is a permission issue (given that "Bypass content access control" worked), but I am not really sure.

I have 6 different pages in this view.

0

https://www.drupal.org/project/commerce/issues/1276450

The above link solved it for me (#5: Disable SQL Rewriting).

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.