0

No matter what I change in the GUI, after clicking save the Expiration of cached pages under Performance options is reset to 6 hours. I checked my default VCL for Varnish suspecting this might be something set there, but couldn't find a 6 (hours) or value of 21600 (6 hours in seconds) there.

I'm pretty new to Varnish so not sure if it might be some default value, or what that could be called (or if Varnish is the culprit here at all, just a hunch).

We need to have Varnish keeping pages cached indefinately by default, and caches to only get cleared when content updates.

2
  • Sounds like you have a module that overrides the form submission.
    – Letharion
    Mar 29, 2012 at 11:38
  • Any other option change on the page sticks, tho. But I guess I could try and dsm() the $form with devel.
    – red
    Mar 29, 2012 at 12:28

1 Answer 1

1

The settings.php file contained the following line, which caused the behavior I was observing.

$conf['page_cache_maximum_age'] = 21600;

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.