2

Using composer I tried to update Drupal 8 to 8.5.6. The update wasn't working, so I changed the dependencies to explicitly require 8.5.6. The update began, but it installed Drupal 8.6.0-beta1. The command I used was composer update drupal/core --with-dependencies -v.

The updates page still says Drupal 8.5.6 is required. I'm not sure where to go from here.

Should I try to roll it back? I tried requiring Drupal 8.6.0-beta2 and Drupal 8.6.0-rc1, but an error suggested not to update to these versions. I want the site live ASAP, and updated to Drupal 8.5.6.

6
  • What does composer why 8.6.0-beta1 and composer why-not 8.5.6 say?
    – mpdonadio
    Sep 5, 2018 at 15:24
  • 1
    I bet my dinner that this is being caused by "minimum-stability": "dev" in your composer.json. Change it to "minimum-stability": "stable" or alpha or beta, whatever fits your needs.
    – leymannx
    Sep 5, 2018 at 16:48
  • Your right it does say "dev". I'm at beta1 what command should I use to get to a stable release suitable for production please?
    – 8en
    Sep 5, 2018 at 18:43
  • As already said, simply change it to "stable". Then save the file, then composer update again. If that doesn't work, delete composer.lock, delete the /vendor folder and then composer install again.
    – leymannx
    Sep 5, 2018 at 18:54
  • I'd tried changing to stable and 8.5. It looked like it was going to revert to 8.5.5 but running the database update lost the site. I then tried Beta2 but that didn't work either so I tried stable and beta1 to try to rescue the situation hence being back to beta1. Deleting folders makes me nervous so I'll double check my recent backup works first and give it a whirl tomorrow when I'm feeling brave. Many thanks
    – 8en
    Sep 5, 2018 at 19:03

1 Answer 1

1

Solution for me was start from 8.5.0, upgrade to 8.5.5 then run:

composer update drupal/core symfony/* --with-dependencies

I'm now on 8.6.0 ! :)

3
  • And you changed "minimum-stability": "dev" to stable, didn't you?
    – leymannx
    Sep 6, 2018 at 12:13
  • 2
    Composer will pick a stable version over an unstable one if it's available @leymannx. No need to change minimum stability for this. For example I have a project with min stability dev, drupal/core required at ~8.5, and composer update gets me to stable 8.6.0.
    – Clive
    Sep 6, 2018 at 12:22
  • Yes I changed to "stable". On the other project I'm developing I'll experiment with both "stable" and "dev". thanks both.
    – 8en
    Sep 6, 2018 at 18:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.