0

I have File Browser installed on my website. The module info can be found here: https://www.drupal.org/project/file_browser

When I go to browse for pictures, there are no images. You can see what I see below:

Lack of Pictures

Below, you can see "WHY" it is not loading. Thumbnails not Found

It seems to think that the system should have generated thumbnails and it is trying to reference those thumbnails. However, the files have not been created.
/sites/default/files/styles/file_entity_browser_thumbnail/public/md-slider-image/slide-corporate-3.jpg?itok=O25-iC4D

My next thought was that maybe the GD manipulation tool was not enabled and the system needed that to generate the thumbnails. I checked using command line and that program is installed.

GD Support => enabled 
GD headers Version => 2.2.4 
GD library Version > => 2.2.4

After further review, I went ahead and discovered that the "image style" functionality of Drupal is what is supposed to be generating the images. So, I went and just tried to use the "normal" image style functionality by adding an image field to a node and attempting to apply a style in "display settings." When I did this, it did not work. So, it seems the issue lies with "Image styles."

The most obvious solution would seem to be that I do not have the permissions set correctly.

I went to /sites/default/files/ and the owner is www-data (apache) and the "octal" is 0777. I also made sure to apply these permissions "recursively" so it would copy down to any sub directories. Nothing seemed to change after doing that. I also am not getting any errors that I can find.

Does anyone have any suggestions on how to fix or where an error might be generated that could point me in the right direction?

  • 1
    Have you checked directory and file permissions to make sure that they are writable by the server? – Ismail Cherri Sep 7 '18 at 0:52
  • Ismail, I did check and I went ahead and updated my question to reflect what I did. The directory where they are supposed to be generated has apache as owner and "0777" set as permission. I think that is as liberal as it can possibly be. – Scott Sep 7 '18 at 13:23
1

The solution for the image style issue was to alter the HTACCESS in that folder so it would allow apache to use image files.

I can also confirm that it WILL NOT work if you do not have your apache rewrite module turned on.

Final note - this will work without the octal being "777" as I mentioned in original post.

0

One of the reasons for this might also be mod_rewrite not being enabled in apache

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.