0

I have a language switcher added to my site. It works fine as long as I'm an unauthenticated user. Logging into site replaces it with:

<span data-big-pipe-placeholder-id="callback=Drupal%5Cblock%5CBlockViewBuilder%3A%3AlazyBuilder&amp;args%5B0%5D=languageswitcher&amp;args%5B1%5D=full&amp;args%5B2%5D&amp;token=nsR3jJa8bJz_M5rp3ogwQZ8Ownrs-S1wckm2wsrv1BY"></span>

I see this behavior also when I add a message block to any of the regions.

I'm also using big pipe. Could it be causing some issue? Is this a bug with language switcher block?

Any help is appreciated.

Thank you

  • 1
    Please don't post links to your projects. It always appears like spam and/or click-bait. Furthermore the questions (and potential answers) on Drupal Answers remain, while your project moves to another domain and so on... - Always describe your problem as good as you can in a textual representation; consider pasting HTML source, error log excerpts, or similar with your question. - Rule of thumb: If you need to paste in a link to your site to make us understand the issue, your question is too broad and needs further information. – Mario Steinitz Sep 11 '18 at 7:19
0

Things you can try one of the following:

  • Uninstall Big Pipe module
  • Try switching to another theme. It might be that the active theme has a JS error which breaks the execution of the Big Pipe
  • Enable JS aggregation if disabled, or disable it if enabled
  • Check for console erros in the developer tools

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.