0

I got a multilanguage configuration with language detection based on URL(/en /fr). Drupal behavior redirects everything to so it would have those two prefixes or, if setup, it will ignore the prefix for a language while keeping for the other.

In my situation I need to keep the prefix for both language except for root page.

Ex:

  • example.com/en -> will load english homepage
  • example.com/fr -> will load french homepage
  • example.com/ -> has to load english homepage but without redirect to /en

So, how can this be achieved?

1 Answer 1

1

Drupal core doesn't redirect everything. Do you have the Redirect module installed? Then disable the route normalizer in the module settings, which is by default enabled:

/admin/config/search/redirect/settings

GLOBAL REDIRECTS

[x] Enforce clean and canonical URLs

If you want to keep the global redirect try this module specifically for the language prefix Disable Route Normalizer.

4
  • That would imply that I need to make my homepage language neutral which is not the case. Sep 18, 2018 at 9:50
  • No, you don't need to do this. You have the module Redirect installed?
    – 4uk4
    Sep 18, 2018 at 10:05
  • yes I have redirect, but still not sure what is your point Sep 18, 2018 at 11:18
  • 1
    It's the module Redirect redirecting everything and not Drupal. You can disable this behavior in the module settings.
    – 4uk4
    Sep 18, 2018 at 11:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.