0

In the composer.json file I added "drupal/core": "~8.4" to the required section. When I run composer update drupal/core --with-all-dependencies, I get the following output.

Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

Problem 1

  • drupal/core 8.4.0 conflicts with acquia/blt-project

Why does Drupal 8.4 conflict with acquia/blt-project?

  • 1
    Read drupal.org/docs/8/update/update-core-via-composer#known-issues and update your question - or add an answer yourself ;-) – hansfn Sep 18 '18 at 17:01
  • Why don't you simply composer update --with-dependencies? I do that every now and then at least once a week and never had any problem. – leymannx Sep 18 '18 at 18:14
  • I’ve been googling this conflict for a day now but haven’t found a solution. This conflict is more about acquia/blt issue I think. Yep done that command also without any luck. – fkaufusi Sep 18 '18 at 21:01
  • 1
    Is there an update to the module that can be run first to avoid the conflict? – LittleCoding Sep 19 '18 at 0:22
  • 2
    Looks like the 8.9.x version is in EOL and only has support for <= D8.5.. look at the 8.8.x or 9.x version for support of D8.4. Have a look at the 9.x README.md github.com/acquia/blt/blob/9.x/docs/README.md – LittleCoding Sep 19 '18 at 3:02
0

The problem was a line in my composer.json file which is prevent the upgrade from happening.

In the "conflict" section, there's a line "drupal/core": ">=8.4.0-alpha1" I have to remove that line and also run the following commands to complete the upgrade.

composer update --lock
composer require acquia/lightning:^3.0 acquia/blt:^8.9 --no-update
composer update acquia/lightning --with-all-dependencies

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.