0

I'm using TB Megamenu on a D8 site. With a bit of tweaking all working fine.. However, when I try to have a third level of links I can't get this to show expanded. In the menu itself the level 2 item and all level 3 items have 'show as expanded' ticked on, to no avail.

In the TB toolbox it shows correct, I can have the level2 item function as header (group set to 'yes') and have the feel 3 links in one or more columns under level 2. But on the site I get a toggle arrow, and no leave three links. And clicking level 2 does not show the level 3 items underneath (I think they're rendered on the right, outside my 100% width submenu).

Structure wanted: level 1 link | level 1 link | etc
level 2 nolink (group yes) | normal level 2 items
level 3 items always expanded as group | level 3 items

(when looking at mobile the level 3 does appear under there level 2, but again not expanded, only unfolding when clicking the level 2 item..)

I have a suspicion I could change the one of the twigs (tb-megamenu-submenu.html.twig? tb-megamenu-subnav.html.twig?) but don't know how..

All help massively appreciated!

0

TB Mega Menu is a pretty awesome module, but we've been using it for a few years and occasionally run into issues where the rendered menu doesn't appear to reflect the menu's structure. It gets "stuck." Here are a few things that have worked for us, in various combinations:

  • Clear your site's cache.
  • Rebuild your site's menus (use devel for this).
  • For the items that aren't showing, create a new parent menu item and move the child items to under the new parent and delete the old parent menu item.

From our troubleshooting, we've determined that TB sometimes seems to "lose track" of the menu and basically all of these efforts are intended to get TB to re-sync.

Hope it helps!

  • Thanks for your suggestion Beau, but I'm afraid this didn't solve the problem. I had already tried your first and third suggestion, rebuilding the menu with level was new so tried that too, and then all three in various sequences.. However, the third level links remain invisible. So the problem must lie in one the templates that generates the TB menu. It simply refuses to group the level 3 items under the level 2 header no-link (it does show it perfectly in the TB toolbox, but not in the actual output), it simply show a toggle arrow.. – xax Sep 22 '18 at 9:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.