1

I created a content type "events", with a date field and other normal settings.

I am trying to use the Calendar module to create a calendar on my Drupal site, but I am facing an issue.
When I try to edit the basic calendar, and change its argument from date:node (node updated time), then in the list of date_fields it does not show the field that I had created above. It only shows the following fields:

  • Node: Last comment time
  • Node: Post date
  • Node: Updated date
  • User: Created date
  • User: Last access
  • User: Last login

I have tried this again and again by recreating my content type, or by disabling/enabling the Calendar module, but it does not seem to work. I am using Date 7.2.x and Calendar 7.2.x.

  • I guess you mean that Views doesn't list the field you created in the list of the view arguments. Drupal 7 fields are not CCK fields; Drupal 7 has its own field API, which doesn't require CCK at all. Also, what you call "cck" is a content type. – kiamlaluno Apr 23 '11 at 12:10
  • oh sorry..i meant content type... – ayush Apr 23 '11 at 12:44
  • There is nothing to be sorry. Using the wrong term confuses who reads the question, especially if the question is about Drupal 7, and you make references to CCK. Somebody could wonder if the question is really for Drupal 7, or for Drupal 6. – kiamlaluno Apr 23 '11 at 12:51
2

I installed Calendar 7.x-2.x-dev, Date 7.x-2.x-dev, and Views 7.x-3.x-dev; then I created a "Test" content type to which I added a date field ("Start date").

When I edited the Calendar view, and added a new argument for the view (view arguments are called "contextual filters," in Views 7.x-3.x-dev), I followed the following steps:

  • I filtered out the list of arguments to show only the ones defined from the Date module; between the two argument types, I selected "Date: Date (node)."
  • On the settings page that Views shows after I selected the argument type, I selected the date field I added to my content type.

first screenshot


second screenshot

If you select "Date: Date (users)," then you will see all the date fields that are associated with users, as in the following screenshot.

third screenshot

Still, the field I added to my content type is visible in the list of fields shown in the settings page for the view argument.

The issue you are seeing is probably caused by compatibily problems between Date, and Views. I would try using Views 7.x-3.x-dev.

| improve this answer | |
  • i should upgrade my views module. that would help i guess. – ayush Apr 23 '11 at 14:57
  • suppose i do upgrade my views version.Then all the previous views that are present on the site would still be functional? – ayush Apr 23 '11 at 15:02
  • @ayush All your views would still be functional. As usual, the suggestion is to first test a new module version on a test site where you enabled the same modules that are enabled in the production site. If you don't see any issues in the test site, then you can be sure the module will not cause any problem on the other site. – kiamlaluno Apr 23 '11 at 15:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.