0

I executed the config:import: import successfully, but now it seems that the theme settings are no longer found. The site is now seen as in the attached image

drupal theme problem

How can I solve the problem?

Note: I don't use bootstrap theme. I imported the configuration I had previously exported from another machine on Ubuntu. This problem is on a Windows machine.

  • Are you using bootstrap theme ? – Pankaj Yogi Sep 21 '18 at 9:46
  • I don't use bootstrap theme. I imported the configuration I had previously exported from another machine on Ubuntu. This problem is on a Windows machine – Alessio Frabotta Sep 21 '18 at 10:01
  • It's look like your theme not loading css and js files. can you please check error in console – Pankaj Yogi Sep 21 '18 at 10:02
  • Please read over your theme's generates HTML, "view source" in your browser. And let's us know if the CSS:JS is full out missing or if you are getting a 404 type error for those files. – LittleCoding Sep 21 '18 at 11:56
  • In Configuration -> Performance I have removed the Aggregate CCS files and JS files checkbox and now it seems to work – Alessio Frabotta Sep 21 '18 at 11:58
0
  1. Double check and confirm that the theme files are exactly were they should be.
  2. Make sure the /files directory exists and writable (NOT 777 permissions though)

  3. Double check and confirm that Drupal can access the files directory via configurations

  4. Clear the Drupal cache

If the theme is using external CSS or JavaScript files, make sure they are accessible. (most cases its an internet connection especially for front-end frameworks like Bootstrap)

  • In the chrome debugger I see this: Refused to apply style from [.....] because its MIME type ('text/html') is not a supported stylesheet MIME type, and strict MIME checking is enabled. – Alessio Frabotta Sep 21 '18 at 10:22
  • In Configuration -> Performance I have removed the Aggregate CCS files and JS files checkbox and now it seems to work – Alessio Frabotta Sep 21 '18 at 10:32

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.