0

I already have a custom content type (jobs). When I create jobs nodes, they are displayed. I have created a new content type (ideas). When I add an idea node, I get a Page not found error. Any new custom content type I create gives me the same error.

The nodes I created are published. I cleared the cache.

I tried re-building the node permissions here: https://www.foo.com/admin/reports/status

Which didn't work.

There does appear to be  Experimental modules found: Content Moderation. This would no longer be experimental in 8.6, currently the site is running 8.2. Not sure if that upgrade would help or create more problems.

There is this error which is interesting:

Mismatched entity and/or field definitions  The following changes were detected in the entity type and field definitions. Content The node.field_recognition_date field needs to be uninstalled.

But I am not sure how to uninstall that or how to fix this issue. Any help would be appreciated.

  • Is there Rabbit Hole? Is there a global redirect of some sort? Is there an htaccess rule about idea it does not like? – Kevin Oct 2 '18 at 19:42
  • No there isn't Rabbit Hole and no to the other aspects. – Chris Rosenau Oct 2 '18 at 21:14
0

Sound like you have removed a dependency from the codebase that a field a certain field depends on, usually it's a module. If that's the case you will need to reinstate it, then uninstall it. But also, you might want to try drush entup and drush updb

Also, it's a good idea to check the error reports for a more detailed explanation of what has happened

  • I ran both of those commands and that didn't fix the issue. But I am guessing that you are right about the dependency, I just have to track that down. – Chris Rosenau Oct 6 '18 at 18:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.