0

I have a custom content type with "Set custom language as default for new content" and "Require language". Custom default language is Current language.

Entity translation is defined with "Current language" as "Default language" and "Exclude Language neutral from the available languages" enabled.

I have 24 languages enabled but when creating a new node, only English appears as a language. But I need to be able to set any of the 24 languages

What am I missing?

1

Change interface lang to the node target lang

The configuration you describe will always only allow one language when creating new nodes: the current language of the interface.

That is because you have Set custom language as default for new content. (and the current one as the default).

If you want to create content in other languages, you have to visit the node creation page in that target language (/fr/node/add/article if you're using prefixes).

Or allow other langs to be chosen

But if you want to be able to choose which language to assign to a node no matter what interface language you're currently using you have to untick the Set custom language as default for new content. while keeping Require language (Do not allow Language Neutral).

That way your interface may be English, but you'll be able to choose any language in a drop-down to assign to that node.

  • I actually first tried to modify the Multilingual settings, but they are not editable. As the node is managed by features and strongarm, I tried to exclude all the variables from being handled by features and in the strongarm file I modified the corresponding definition i18n_node_options_ but a feature update doesn't change anything. – abelass Oct 12 '18 at 7:53
  • I put Current language as the default language because this was the only parameter I was able to change. The language however doesn't adapt to the interface. So even if I have /fr/node/add/project_fr and an interface well in French, I still only get English as only available language. – abelass Oct 12 '18 at 7:58
0

Please check the following:
1. In Entity translation settings page: "Use only enabled languages" is checked or not
2. If it is checked, then check in the admin/config/regional/language page that all languages are actually enabled not just added
3. If languages are added and enabled, then uncheck the option in 1

  • All the languages were already enabled, I followed your steps though, and nothing changed, only English is available – abelass Oct 12 '18 at 7:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.