7

It took me a while to figure out how to remove the language switches from the bottom of each page. Eventually the switch was in a somewhat logical location (Multilanguage settings > Article options). (Oh, new question. I translated those menu items myself, because - mysteriously - my "backend" is in German. I don't remember how that happened. Everything I can find, default language, user language, is set to English. Where can the "backend" language be set?)
But what I've come here for:
There still is a language indicator at the bottom of each page ("Language: English"), and I cannot find how to get rid of that. CSS would be fine, but it does not have a specific class/id, so I cannot grab it.

14

Home » Administration » Configuration » Regional and language » Multilingual settings

then

go to the "Node Options" tab

check

Hide content translation links

  • This was the one and only solution for me! Thanks! – Michiel May 28 '13 at 7:37
  • 1
    Node options tab is gone .. – commonpike Oct 25 '14 at 23:46
  • 2
    Did not work for me, but @skwashd's answer did – Josh Mar 9 '15 at 17:02
5

You haven't mentioned if you're using Drupal 6 or 7. I only have experience with i18n on D7 and my answer is based on that experience.

Visit http://example.com/admin/structure/types/manage/[content-type]/display (Admin > Structure > Content types > [Content Type] > Manage Display) and set language to hidden.

Answer to bonus question: Visit http://example.com/user and you can set your default language

  • Thanks, Dave. It's D7, sorry. Alright, language is now hidden on most pages. But it is still there on the home page. I went through all content types (only three of them), but only the simple page type has the language setting. Admin language: Yes, there is a language option in the users settings. Always set to English, but backend is still German. (As I said in my question: "Everything I can find, default language, user language, is set to English.") Only a few menu items ("Dashboard", "Find content") are in English. – Ralf Apr 2 '12 at 6:14
  • I found the admin language issue solution! "Determine the language from the URL" is enabled, and there was /de/ in the URL. Surely makes sense to determine language from url in the frontend. But in the backend? Now whereever I am on the site when choosing to edit a page, the language of that page determines the admin menu language. Is there a way to change that? Or am I the only one who perceives that as a problem? – Ralf Apr 2 '12 at 6:27
  • ... and it does not help to turn the URL detection setting off, because the "?language=de" is added to the URL, and admin menu is in German again ... – Ralf Apr 2 '12 at 6:32
  • Got it: drupal.stackexchange.com/questions/13476/… --- the trick is that the order of the detection methods must be set, too. – Ralf Apr 2 '12 at 6:42
  • This worked for me, Mohamed Adly's answer did not. – Josh Mar 9 '15 at 17:03
3

I found it! Or so I believe, but currently it seems to work:

In Structure » Content types » Simple Page » Manage display ... there is an area "CUSTOM DISPLAY SETTINGS". Checkmarking "Teaser" there adds an option to edit settings for teasers where the language indicator can be hidden.

  • If it solved your problem, you should mark your own answer as accepted! Thanks! (btw., I think Dave Hall's answer was a solution too... but he couldn't guess what customized displays you turned on, because you didn't post a screenshot) – Sk8erPeter Apr 4 '12 at 20:19
  • Thanks, Peter. I didn't know about customized displays, so would not have known of what to take a screenshot ... – Ralf Apr 5 '12 at 21:58
  • Clear. :) I upvoted your answer and Dave Hall's too, both of them can be useful for someone. – Sk8erPeter Apr 5 '12 at 22:09
3

None of the above worked for me. In case it helps future readers, there is a different solution if you are using Drupal 7 plus the Entity translation module.

In Structure > Content types > [Content Type] > Edit, select "Publishing options" then tick "Hide content translation links".

-1

For Drupal 7:

In Structure > Content types > [Content Type] > Edit, select "Publishing options" then click "Disable" under "Multilingual support".

  • But this will disable multilingual support, and OP wants only to hide indicator. – Mołot Dec 31 '15 at 1:13
  • In » Administration » Configuration » Regional and language just add your language, make it be the default language then you still can use your language on the site even you disable "Multilingual support" in "Publishing options." It works for the Vietnamese language. – Timothy Huynh Dec 31 '15 at 1:21
  • Still, it seems to be removing functionality OP don't want removed. He seems to want to have multilingual nodes, just not the indicator. – Mołot Dec 31 '15 at 1:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.