0

I've upgrade my core from 8.6.1 to 8.6.2 with composer (the installation have not been done with composer, so I add drupal/core in composer with this command: composer require drupal/core:8.6.2 --update-with-dependencies (solved here).

Core is updated, by I obtain this output.

Dependency "doctrine/common" is also a root requirement, but is not explicitly whitelisted. Ignoring.
Dependency "easyrdf/easyrdf" is also a root requirement, but is not explicitly whitelisted. Ignoring.
Dependency "egulias/email-validator" is also a root requirement, but is not explicitly whitelisted. Ignoring.
Dependency "guzzlehttp/guzzle" is also a root requirement, but is not explicitly whitelisted. Ignoring.
Dependency "masterminds/html5" is also a root requirement, but is not explicitly whitelisted. Ignoring.
Dependency "paragonie/random_compat" is also a root requirement, but is not explicitly whitelisted. Ignoring.
Dependency "stack/builder" is also a root requirement, but is not explicitly whitelisted. Ignoring.
Dependency "symfony-cmf/routing" is also a root requirement, but is not explicitly whitelisted. Ignoring.
Dependency "symfony/class-loader" is also a root requirement, but is not explicitly whitelisted. Ignoring.
Dependency "symfony/console" is also a root requirement, but is not explicitly whitelisted. Ignoring.
Dependency "symfony/dependency-injection" is also a root requirement, but is not explicitly whitelisted. Ignoring.
Dependency "symfony/event-dispatcher" is also a root requirement, but is not explicitly whitelisted. Ignoring.
Dependency "symfony/http-foundation" is also a root requirement, but is not explicitly whitelisted. Ignoring.
Dependency "symfony/http-kernel" is also a root requirement, but is not explicitly whitelisted. Ignoring.
Dependency "symfony/polyfill-iconv" is also a root requirement, but is not explicitly whitelisted. Ignoring.
Dependency "symfony/process" is also a root requirement, but is not explicitly whitelisted. Ignoring.
Dependency "symfony/psr-http-message-bridge" is also a root requirement, but is not explicitly whitelisted. Ignoring.
Dependency "symfony/routing" is also a root requirement, but is not explicitly whitelisted. Ignoring.
Dependency "symfony/serializer" is also a root requirement, but is not explicitly whitelisted. Ignoring.
Dependency "symfony/translation" is also a root requirement, but is not explicitly whitelisted. Ignoring.
Dependency "symfony/validator" is also a root requirement, but is not explicitly whitelisted. Ignoring.
Dependency "symfony/yaml" is also a root requirement, but is not explicitly whitelisted. Ignoring.
Dependency "twig/twig" is also a root requirement, but is not explicitly whitelisted. Ignoring.
Dependency "zendframework/zend-diactoros" is also a root requirement, but is not explicitly whitelisted. Ignoring.
Dependency "zendframework/zend-feed" is also a root requirement, but is not explicitly whitelisted. Ignoring.
Loading composer repositories with package information
Updating dependencies (including require-dev)
Package operations: 0 installs, 1 update, 0 removals
  - Updating drupal/core (8.6.1 => 8.6.2): Loading from cache
> Drupal\Core\Composer\Composer::vendorTestCodeCleanup
Writing lock file
Generating autoload files
> Drupal\Core\Composer\Composer::preAutoloadDump
> Drupal\Core\Composer\Composer::ensureHtaccess
04:08:01 {master} ~/Websites/ildeposito8.local$ 

I notice that symfony is not upgraded (on a fresh installation symfony version is 3.4.17:

04:09:09 {master} ~/Websites/ildeposito8.local$ composer show | grep symfony
stecman/symfony-console-completion    0.8.0              Automatic BASH com...
symfony-cmf/routing                   1.4.1              Extends the Symfon...
symfony/browser-kit                   v3.4.14            Symfony BrowserKit...
symfony/class-loader                  v3.4.14            Symfony ClassLoade...
symfony/config                        v3.4.14            Symfony Config Com...
symfony/console                       v3.4.14            Symfony Console Co...
symfony/css-selector                  v3.4.14            Symfony CssSelecto...
symfony/debug                         v3.4.14            Symfony Debug Comp...
symfony/dependency-injection          v3.4.14            Symfony Dependency...
symfony/dom-crawler                   v3.4.14            Symfony DomCrawler...
symfony/event-dispatcher              v3.4.14            Symfony EventDispa...
symfony/filesystem                    v3.4.14            Symfony Filesystem...
symfony/finder                        v3.4.14            Symfony Finder Com...
symfony/http-foundation               v3.4.14            Symfony HttpFounda...
symfony/http-kernel                   v3.4.14            Symfony HttpKernel...
symfony/phpunit-bridge                v3.4.14            Symfony PHPUnit Br...
symfony/polyfill-ctype                v1.8.0             Symfony polyfill f...
symfony/polyfill-iconv                v1.8.0             Symfony polyfill f...
symfony/polyfill-mbstring             v1.8.0             Symfony polyfill f...
symfony/polyfill-php70                v1.8.0             Symfony polyfill b...
symfony/polyfill-php72                v1.9.0             Symfony polyfill b...
symfony/process                       v3.4.14            Symfony Process Co...
symfony/psr-http-message-bridge       v1.0.2             PSR HTTP message b...
symfony/routing                       v3.4.14            Symfony Routing Co...
symfony/serializer                    v3.4.14            Symfony Serializer...
symfony/translation                   v3.4.14            Symfony Translatio...
symfony/validator                     v3.4.14            Symfony Validator ...
symfony/var-dumper                    v4.1.3             Symfony mechanism ...
symfony/yaml                          v3.4.14            Symfony Yaml Compo...
04:09:11 {master} ~/Websites/ildeposito8.local$ 

The same thing I download to 8.6.1 and then I try to run "compose update drupal/core --with-dependencies

Have I to upgrade symfony? How?

  • 1
    You could run composer require webflo/drupal-core-strict, then you won't have to worry about it any more. That package will make sure you have the right versions of core dependencies – Clive Oct 19 '18 at 14:42
  • Thanks, but nothing changes. I add "webflo/drupal-core-strict" but symfony is always on 3.1.14. I also tried to run composer update webflo/drupal-core-strict --with-dependencies – arrubiu Oct 19 '18 at 14:49
  • Did you try to a composer update after requiring that package? Not sure if it's needed but worth a shot – Clive Oct 19 '18 at 14:51
  • I've tried to remove vendor directory and then "composer install", but nothing changes. Running "composer update" I update ALL composer packages, I don't know if it is the right way (but works). – arrubiu Oct 19 '18 at 14:54
  • This is the recommended way so IMO this should suffice – Ismail Cherri Oct 19 '18 at 16:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.