0

I've got a fresh install of Drupal 8.6.x with REST/API/JSON Web Services enabled and I've created a Rest export View with path: /api/test which returns the correct JSON View results when I append the required querystring:

?_format=json

So all is well. Until I either create a second REST export View or a new Display in the working View. These seem to work fine in the View's UI Preview but also displays "This display has no path" just above the Preview output. If I go to the new View/Display's URL I get Page Not Found and if I append ?_format=json I get this:

{
"message": "No route found for \"GET /api/temp-view\""
}

(/api/temp-view is my second View's path).

It's the strangest thing. Only the first, original view Display is working. I've created all sorts of different URL paths to test (and Saved each time). The View settings are standard and identical.

I've spent about 6 hours on this now...

Any help much appreciated.

0

I've managed to figure it out finally. I was following instructions and installed Drupal Cors (https://www.drupal.org/project/cors) which is now a part of Drupal 8.2.x and I was getting:

PHP Fatal error:  Redefinition of parameter $config_factory

in my php_error.log.

I uninstalled Drupal Cors module and it's working as expected.

daywasted

  • I don’t know why this module would be needed, but it sounds like a bug to be filed in that module issue queue. – Kevin Oct 30 '18 at 18:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.