0

I have a REST export which provides data with a call (curl or browser) to the Drupal URL(s). But we need to get these data over a curl to vhosts IP-Address and from this address, which is 192.168.34.11.

curl http://drupal.url/view.json from every other device and curl http://192.168.34.11/view.json from others in the same NAT works.

curl http://192.168.34.11/view.json local from 192.168.34.11 does not work. In this case I only get []

There are no access or permission restrictions set in the view. We use the https://www.drupal.org/project/domain module and I have configured a domain 192.168.34.11.

Why isn't the view accessible over it's localhost IP address?

  • If you disable the domain module does the problem persist? If not it's probably domain-based permissions – Clive Nov 2 '18 at 11:08
  • I'm confused. Disabling the Domain module changes nothing. But: I created a new REST view for the same node type and only 2 fields. In preview and with a browser I see all nodes. But with curl I see only 1. This one has nothing special. Crazy. – deelite Nov 5 '18 at 20:11
  • When I set the permission "Bypass content access control" for guests, I get all nodes via curl. – deelite Nov 5 '18 at 20:40
0

OK, solved. The problem was the domain access module.

I got no output because I didn't set the domain access for all nodes except one. The one I got in ouput.

There is no default value for the domain access field in field configuration in node type configuration. And it's not comfortable to set the domain access values for every single node in node edit. So I needed to disable this module.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.