1

I'm trying to use Drupal 8, but if Drupal 7 is better for that, I'm ready to go back to Drupal 7.

I have a vocabulary that must contain at least 10,000 terms, but they can also become more than 100,000. For the sake of simplicity, I chose to make only one vocabulary, without hierarchy.

I quickly reached the limits of my server, and I regularly get WSODs, especially when I try to edit the vocabulary.

I tried to increase the limits of memory (I am under MAMP), but I still have errors. Here is the error:

Fatal error: Allowed memory size of 536870912 bytes exhausted (tried to allocate 20480 bytes) in /core/lib/Drupal/Core/Entity/Sql/Sq

How can I avoid these problems?
Is it preferable to split the vocabulary?

  • Way too broad. Many sites out there have thousands of terms or millions of nodes. Sounds more like a server tuning problem? – Kevin Nov 5 '18 at 15:46
  • It's strange. I'm using MAMP yet, with the default settings. I pushed the limit of the memory to 512M ... Are there any other settings to be made? – Hgfdsoiu Nov 5 '18 at 15:51
  • Please post the error message from Apache logs or from Drupal error log when you get a white screen. Also, enabling error display in php.ini can help a lot in this matter – Ismail Cherri Nov 5 '18 at 15:55
  • PHP memory limit over 256MB isn't going to be any more beneficial to you. – Kevin Nov 5 '18 at 16:04
  • 1
    Is it just a matter of loading the taxonomy overview page? Replace it with a paged view for better results? Not really a lot of other information here. – Kevin Nov 5 '18 at 16:44
0

Since i can't answer it in comment. i'll try to answer here. I've solve similar problem, my solution is using redis caching and entity cache module

Since then, my site going well with 256MB RAM configuration in php.ini.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.