I have 3 contextual filters in a view and I use them to override the views title. However, still, the page title (title in the browser tab) are still using the default title of the view. How can I make it use the title provided from the contextual filters?

Most themes output the main page title also into the <title> element in the HTML <head>, usually with the site name appended.

The title you see in the browser tab should be the same as the main title you see on the page, unless your theme does something different (unlikely) or you're using a module that changes the Page title (for example Metatag).

The Override title option is only activated When the filter value IS in the URL or a default is provided. If this option isn't kicking in when it seems it should (either in page title or in the browser tab) then there is no contextual filter or it doesn't validate in some way. This is most likely a problem with your contextual filter configuration.

If you're still having problems please post your Contextuals configuration and what steps you're taking to test it.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.