1

Last time I used composer on my project was to update drupal core from 8.6.2 to 8.6.3 using composer update drupal/core webflo/drupal-core-require-dev --with-dependencies and to update the webform module from 8.x-5.0-rc24 to 8.x-5.0-rc26 using composer require 'drupal/webform:^5.0' and after both successful updates, my website is working perfectly but any Composer command I use is returning the same error.

Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - The requested package algolia/places 1.13.0 is satisfiable by algolia/places[1.13.0] but these conflict with your requirements or minimum-stability.
  Problem 2
    - The requested package codemirror/codemirror 5.41.0 is satisfiable by codemirror/codemirror[5.41.0] but these conflict with your requirements or minimum-stability.
  Problem 3
    - The requested package jquery/inputmask 4.0.2 is satisfiable by jquery/inputmask[4.0.2] but these conflict with your requirements or minimum-stability.
  Problem 4
    - The requested package jquery/intl-tel-input 14.0.4 is satisfiable by jquery/intl-tel-input[14.0.4] but these conflict with your requirements or minimum-stability.
  Problem 5
    - The requested package jquery/timepicker 1.11.14 is satisfiable by jquery/timepicker[1.11.14] but these conflict with your requirements or minimum-stability.

The Composer commands I tried so far are:

  • composer update

  • composer update drupal/core webflo/drupal-core-require-dev --with-dependencies

  • composer require "webflo/drupal-finder ~1.0.0"

As I remember, the following packages are used by the Webform module and this module is updated to the latest stable release version.

  • algolia/places

  • codemirror/codemirror

  • jquery/inputmask

  • jquery/intl-tel-input

  • jquery/timepicker

I have tried both the solutions mentioned in Conflict between package requirements when updating to Drupal 8.4 but with no success at all.

What is going on?

UPDATE #1:

Here is my composer.json file:

{
    "name": "drupal-composer/drupal-project",
    "description": "Project template for Drupal 8 projects with composer",
    "type": "project",
    "license": "GPL-2.0-or-later",
    "authors": [
        {
            "name": "",
            "role": ""
        }
    ],
    "repositories": {
        "0": {
            "type": "composer",
            "url": "https://packages.drupal.org/8"
        },
        "drupal": {
            "type": "composer",
            "url": "https://packages.drupal.org/8"
        }
    },
    "require": {
        "algolia/places": "1.10.0",
        "ckeditor/autogrow": "4.10.0",
        "ckeditor/codemirror": "v1.17.7",
        "ckeditor/fakeobjects": "4.10.0",
        "ckeditor/image": "4.10.0",
        "ckeditor/link": "4.10.0",
        "codemirror/codemirror": "5.40.0",
        "composer/installers": "^1.2",
        "cweagans/composer-patches": "^1.6.5",
        "drupal-composer/drupal-scaffold": "^2.5",
        "drupal/admin_toolbar": "^1.24",
        "drupal/ajax_links_api": "^1.0",
        "drupal/backup_migrate": "^4.0",
        "drupal/barcodes": "^1.8",
        "drupal/better_exposed_filters": "^3.0",
        "drupal/bootstrap": "^3.13",
        "drupal/bootstrap_layouts": "^5.1",
        "drupal/bootstrap_library": "^1.11",
        "drupal/business_rules": "^1.0",
        "drupal/captcha": "^1.0",
        "drupal/color_field": "^2.0",
        "drupal/conditional_fields": "^1.0",
        "drupal/config_split": "^1.3",
        "drupal/console": "^1.0.2",
        "drupal/core": "^8.6.0",
        "drupal/devel": "^1.2",
        "drupal/ds": "^3.1",
        "drupal/entity_reference_views_select": "^1.3",
        "drupal/eva": "^1.3",
        "drupal/field_group": "^3.0",
        "drupal/field_permissions": "^1.0",
        "drupal/fontawesome": "^2.9",
        "drupal/footable": "1.x-dev",
        "drupal/group": "^1.0",
        "drupal/module_filter": "^3.1",
        "drupal/pathauto": "^1.2",
        "drupal/readonlymode": "^1.0",
        "drupal/reroute_email": "^1.0",
        "drupal/search_api": "^1.10",
        "drupal/simplify": "^1.0",
        "drupal/sms": "^1.1",
        "drupal/sms_simplegateway": "^1.1",
        "drupal/telephone_validation": "^2.1",
        "drupal/token": "^1.5",
        "drupal/toolbar_menu": "^2.1",
        "drupal/toolbar_menu_clean": "^1.0",
        "drupal/views_autorefresh_d8": "^1.1",
        "drupal/views_bootstrap": "^3.0",
        "drupal/views_conditional": "^1.0",
        "drupal/webform": "^5.0",
        "drush/drush": "^9.0.0",
        "jquery/image-picker": "0.3.0",
        "jquery/inputmask": "4.0.0",
        "jquery/intl-tel-input": "13.0.0",
        "jquery/rateit": "1.1.1",
        "jquery/select2": "4.0.5",
        "jquery/textcounter": "0.8.0",
        "jquery/timepicker": "1.11.13",
        "progress-tracker/progress-tracker": "1.4.0",
        "signature_pad/signature_pad": "2.3.0",
        "vlucas/phpdotenv": "^2.4",
        "webflo/drupal-finder": "^1.0.0",
        "webmozart/path-util": "^2.3",
        "wikimedia/composer-merge-plugin": "^1.4"
    },
    "require-dev": {
        "webflo/drupal-core-require-dev": "^8.6.0"
    },
    "conflict": {
        "drupal/drupal": "*"
    },
    "minimum-stability": "dev",
    "prefer-stable": true,
    "config": {
        "sort-packages": true
    },
    "autoload": {
        "classmap": [
            "scripts/composer/ScriptHandler.php"
        ],
        "files": [
            "load.environment.php"
        ]
    },
    "scripts": {
        "pre-install-cmd": [
            "DrupalProject\\composer\\ScriptHandler::checkComposerVersion"
        ],
        "pre-update-cmd": [
            "DrupalProject\\composer\\ScriptHandler::checkComposerVersion"
        ],
        "post-install-cmd": [
            "DrupalProject\\composer\\ScriptHandler::createRequiredFiles"
        ],
        "post-update-cmd": [
            "DrupalProject\\composer\\ScriptHandler::createRequiredFiles"
        ]
    },
    "extra": {
        "merge-plugin": {
            "include": [
                "web/modules/contrib/webform/composer.libraries.json"
            ]
        },
        "patchLevel": {
            "drupal/core": "-p2"
        },
        "installer-paths": {
            "web/core": [
                "type:drupal-core"
            ],
            "web/libraries/{$name}": [
                "type:drupal-library"
            ],
            "web/modules/contrib/{$name}": [
                "type:drupal-module"
            ],
            "web/profiles/contrib/{$name}": [
                "type:drupal-profile"
            ],
            "web/themes/contrib/{$name}": [
                "type:drupal-theme"
            ],
            "drush/Commands/{$name}": [
                "type:drupal-drush"
            ]
        },
        "drupal-scaffold": {
            "initial": {
                ".editorconfig": "../.editorconfig",
                ".gitattributes": "../.gitattributes"
            }
        }
    }
}
  • 3
    Whats the output of composer why-not <package> ? – Insasse Nov 13 '18 at 12:46
  • can you please specify what <package> you want to run the command why-not on !? – Elie Masaad Nov 13 '18 at 13:57
  • @Insasse composer why-not algolia/places drupal-composer/drupal-project - requires algolia/places (1.10.0) composer why-not codemirror/codemirror drupal-composer/drupal-project - requires codemirror/codemirror (5.40.0) composer why-not jquery/inputmask drupal-composer/drupal-project - requires jquery/inputmask (4.0.0) composer why-not jquery/intl-tel-input drupal-composer/drupal-project - requires jquery/intl-tel-input (13.0.0) composer why-not jquery/timepicker drupal-composer/drupal-project - requires jquery/timepicker (1.11.13) – Elie Masaad Nov 13 '18 at 14:01
  • 1
    Why you need drupal-composer/drupal-project in your composer.json as required package? What if you remove that? – Insasse Nov 13 '18 at 14:55
  • 1
    webforms should handle these packages on its own so you dont have to require them. cgit.drupalcode.org/webform/tree/composer.libraries.json – Insasse Nov 14 '18 at 8:10
2

Webforms should handle these packages on its own, so you don't have to require them.

See: cgit.drupalcode.org/webform/tree/composer.libraries.json

In general if the package you required has its own composer.json require section you don't have to require them yourself.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.