I have a site which is bilingual (English, Greek).

When I create a view with content, I get duplicate entries of the content.

In the view under Rendering Language I have Interface text language selected for page

I added the Original Language filter to see what is happening and I discovered my content is not showing at all in the view when I set the filter to Greek. When I set the filter to English I get duplicate results. By duplicate I don't mean both languages actually but the English language two times.

I have also checked my nodes and both translations look OK.

I have set the filter to Translation Language and not Original Language and now I can see my content correctly. Is this the expected behavior?

  • 2
    You're getting one result per language that the node is translated into, but each of those results is rendering in the current language, so you get two visually identical results. Yes, setting a filter on the translation language is the correct solution in my experience – Clive Nov 27 at 10:40
  • @Clive Thanks for the input. I think you can add an answer to this question. – pierostz Nov 27 at 12:42
  • Instead of using original language filter use Translation language filter and check "Interface text language selected for page" – Vikram fz16 Nov 27 at 14:08
  • @Vikram fz16 Yes as I did. See my edit. Thanks for the input. – pierostz Nov 27 at 14:35

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.