-1

We use the following for our local development environment. When we run composer require 'drupal/module_name:^1.1', we get the following error message. We have doubled checked that all settings for Acquia Dev Desktop are set to php7.1.11, but still getting this message.

Error Message:

Problem 1

- symfony/browser-kit v4.1.7 requires php ^7.1.3 -> your PHP version (5.6.32) does not satisfy that requirement.
- symfony/browser-kit v4.1.7 requires php ^7.1.3 -> your PHP version (5.6.32) does not satisfy that requirement.
- symfony/browser-kit v4.1.7 requires php ^7.1.3 -> your PHP version (5.6.32) does not satisfy that requirement.
- Installation request for symfony/browser-kit (locked at v4.1.7) -> satisfiable by symfony/browser-kit[v4.1.7].

Local Development environment:

  1. Acquia Dev Desktop
  2. Dev Desktop set to php v7.1.1
  3. Using git bash by navigating to ~/Sites/local-dev/dev

Running php --version in the ~/Sites/local-dev/dev (which is one level above docroot) we get php 5.6.32

Why am I still getting the your PHP version (5.6.32) does not satisfy that requirement even though Acquia Dev Desktop is set to phpv7.1.11?

closed as off-topic by leymannx, Shawn Conn, mradcliffe, Alfred Armstrong, DRUPWAY Dec 7 '18 at 4:53

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions on programming, PHP, SQL, etc. that do not relate directly to Drupal are off-topic here, but can be asked on Stack Overflow." – leymannx, Shawn Conn, mradcliffe, Alfred Armstrong, DRUPWAY
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    The problem is the version of PHP used in your shell. Are you launching the shell using Acquia Dev Desktop, by clicking on the terminal icon (which is located on the same height as "Local code")? – Watergate Nov 30 '18 at 23:23
  • @Watergate no, i have been using git bash in the ~/Sites/local-dev/dev directory – usernameabc Nov 30 '18 at 23:28
  • Then you have to update the PHP version used by Git BASH, or instruct Git BASH to use the correct PHP version located in the DevDesktop folder. – Watergate Nov 30 '18 at 23:48
  • I assume your using Windows, in that case I can recommend using WSL. WSL provides a full Bash shell based on Ubuntu. I'm using it myself for all command line functionality, such as git (flow), composer, drush, etc. You can use apt-get to install such as php, mysql, etc. To make it fully work with Drupal, the only thing you need to do is to enter the database credentials in the settings.php which you can find in the DEVDESKTOP_DRUPAL_SETTINGS_DIR (typically: ['driver' => 'mysql', 'database' => '<db-name>', 'username' => 'drupaluser', 'password' => '', 'host' => '127.0.0.1', 'port' => 33067]. – Watergate Nov 30 '18 at 23:58
  • I really can't stress enough using a better VM setup, one that you can ssh into the box and avoid these host level issues. – Kevin Dec 1 '18 at 15:50
1

After searching, I found out that I had an outdated composer so I did the following steps and now composer is seeing the correct php version.

Previous version of composer was 1.6.3 and php version 5.6.32

Steps:

  1. ran composer self-update
  2. ran composer diagnose and observed the following below

Checking platform settings: OK

Checking git settings: OK

Checking http connectivity to packagist: OK

Checking https connectivity to packagist: OK

Checking github.com oauth access: OK

Checking disk free space: OK

Checking pubkeys: Tags Public Key Fingerprint: xxxxx

Dev Public Key Fingerprint: xxxxx

OK Checking composer version: OK

Composer version: 1.8.0

PHP version: 7.1.11

PHP binary path: C:\path\to\devdesktop\php7_1\php.exe

Not the answer you're looking for? Browse other questions tagged or ask your own question.