-1

Drupal version was 8.6.2 and moved to new server. When doing the core update , getting an error like below.

 Problem 1
- remove drupal/drupal No version set (parsed as 1.0.0)|remove drupal/core 8.6.3
- don't install drupal/core 8.6.2|remove drupal/drupal No version set (parsed as 1.0.0)
- don't install drupal/core 8.6.3|remove drupal/drupal No version set (parsed as 1.0.0)
- don't install drupal/core 8.6.x-dev|remove drupal/drupal No version set (parsed as 1.0.0)
- don't install drupal/core 8.7.x-dev|remove drupal/drupal No version set (parsed as 1.0.0)
- don't install drupal/core 8.6.3|remove drupal/drupal No version set (parsed as 1.0.0)
- Installation request for drupal/drupal No version set (parsed as 1.0.0) -> satisfiable by drupal/drupal[No version set (parsed as 1.0.0)].
- Installation request for drupal/core ^8.6.2 -> satisfiable by drupal/core[8.6.2, 8.6.3, 8.6.x-dev, 8.7.x-dev]

i have tried the composer install by removing composer.lock, vendor and core. Still getting same error.

Updated with my composer.json

{
"name": "drupal/drupal",
"description": "Drupal is an open source content management platform powering millions of websites and applications.",
"type": "project",
"license": "GPL-2.0+",
"require": {
    "composer/installers": "^1.0.24",
    "wikimedia/composer-merge-plugin": "^1.4",
    "drupal/core": "^8.6.2",
    "drush/drush": "^9.2",
    "drupal/s3fs": "^3.0",
    "drupal/csv_serialization": "^1.4"
},
"minimum-stability": "dev",
"prefer-stable": true,
"config": {
    "preferred-install": "dist",
    "autoloader-suffix": "Drupal8"
},
"extra": {
    "_readme": [
        "By default Drupal loads the autoloader from ./vendor/autoload.php.",
        "To change the autoloader you can edit ./autoload.php.",
        "This file specifies the packages.drupal.org repository.",
        "You can read more about this composer repository at:",
        "https://www.drupal.org/node/2718229"
    ],
    "merge-plugin": {
        "include": [
            "core/composer.json"
        ],
        "recurse": false,
        "replace": false,
        "merge-extra": false
    },
    "installer-paths": {
        "core": ["type:drupal-core"],
        "modules/contrib/{$name}": ["type:drupal-module"],
        "profiles/contrib/{$name}": ["type:drupal-profile"],
        "themes/contrib/{$name}": ["type:drupal-theme"],
        "drush/contrib/{$name}": ["type:drupal-drush"],
        "modules/custom/{$name}": ["type:drupal-custom-module"],
        "themes/custom/{$name}": ["type:drupal-custom-theme"]
    }
},
"autoload": {
    "psr-4": {
        "Drupal\\Core\\Composer\\": "core/lib/Drupal/Core/Composer"
    }
},
"scripts": {
    "pre-autoload-dump": "Drupal\\Core\\Composer\\Composer::preAutoloadDump",
    "post-autoload-dump": [
      "Drupal\\Core\\Composer\\Composer::ensureHtaccess"
    ],
    "post-package-install": "Drupal\\Core\\Composer\\Composer::vendorTestCodeCleanup",
    "post-package-update": "Drupal\\Core\\Composer\\Composer::vendorTestCodeCleanup"
},
"repositories": [
    {
        "type": "composer",
        "url": "https://packages.drupal.org/8"
    }
]

}

  • I don't undestand the downvotes for the question. – Néstor Feb 20 at 23:43
0

I think the composer error messages are really opaque: Took me the whole day to figure this one out. And stil am not sure how to debug the composer related problems (and I have read all the drupal documentation, lots of composer documentation, so maybe I am just losing IQ points lately...)

Error 1: composer install

I had the same problem on composer install (Clive removed my earlier remark) and thought the culprit was

remove drupal/drupal No version set (parsed as 1.0.0)

Couldn't figure out why that would happen: Added all modules neatly with require bladiebla and had no problem updating core to 8.6.4

Site was running smoothly

Error 2: install module

Trying to install backup_migrate resulted in the error

The package is not available in a stable-enough version according to your minimum-stability setting

Which I also did not understand because my minimum stability was dev and the backup_migrate version was a stable one

Trying different things to find out where the problem originates did not bring any solution

composer install composer update composer diagnose composer why composer give me a break etc

Is supposed that one of the modules I required conflicted with another one, but how to find out which one..... (any hints on how to debug these composer message are welcome)

SOLUTION (in my case)

In the end I simply did this

starting point

drupal 8.6.4

minimum stability dev

php 7.0.3

actions

  1. remove core, modules/contrib, vendor, composer.lock

  2. in composer.json:

2.1 start with (in my case)

    "drupal/core": "~8.6.0",
    "composer/installers": "^1.0.24",
    "wikimedia/composer-merge-plugin": "^1.4",

2.2 in the following require part require all advised highest version for all modules you use (so go to the drupal mordules site en copy the advised composer require statements)

   "drush/drush": "~9",
    "drupal/backup_migrate": " ^4.0",
    "drupal/backup_db": " ^1.1",
    "drupal/draggableviews": " ^1.0",
    "drupal/pathauto": " ^1.0",
    "drupal/token": " ^1.0",
    "drupal/anonymous_redirect": "^2.2",
    "drupal/ctools": " ^3.0",
    "drupal/calendar": " ^1.0",
    "drupal/geolocation": "^2.0",
    "drupal/views_taxonomy_term_name_depth": "6.x-dev",
    "drupal/views_templates": "^1.0",
    "drupal/paragraphs": " ^1.5",
    "drupal/devel": "^1.2",
    "drupal/webform": " ^5.0",
    "drupal/social_login": " ^2.83",
    "drupal/disqus": " ^1.0",
    "drupal/address": " ^1.4",
    "drupal/leaflet": " ^1.0",
    "drupal/geofield": "^1.0",
    "drupal/geophp": "^1.0",
    "drupal/geocoder": "^2.0",
    "drupal/geofield_map": "^2.20",
    "drupal/google_analytics": "^3.0",
    "drupal/video_embed_field": "^2.0",
    "drupal/better_exposed_filters": "^3.0",
    "drupal/addtoany": "^1.10",
    "drupal/typed_data": "^1.0",
    "drupal/rules": "^3.0",
    "drupal/honeypot": "^1.29",
    "drupal/field_group": " ^3.0"
  1. run composer install
  2. go to your site and run www.domain.ext/update.php

That resolved my problem

0

Check the composer.json in drupal core, I think you have an old composer.json setting, here composer.json drupal 8.6.7 :

{
    "name": "drupal/drupal",
    "description": "Drupal is an open source content management platform powering millions of websites and applications.",
    "type": "project",
    "license": "GPL-2.0-or-later",
    "require": {
        "composer/installers": "^1.0.24",
        "wikimedia/composer-merge-plugin": "^1.4"
    },
    "replace": {
        "drupal/core": "^8.6"
    },
    "minimum-stability": "dev",
    "prefer-stable": true,
    "config": {
        "preferred-install": "dist",
        "autoloader-suffix": "Drupal8"
    },
    "extra": {
        "_readme": [
            "By default Drupal loads the autoloader from ./vendor/autoload.php.",
            "To change the autoloader you can edit ./autoload.php.",
            "This file specifies the packages.drupal.org repository.",
            "You can read more about this composer repository at:",
            "https://www.drupal.org/node/2718229"
        ],
        "merge-plugin": {
            "include": [
                "core/composer.json"
            ],
            "recurse": true,
            "replace": false,
            "merge-extra": false
        },
        "installer-paths": {
            "core": ["type:drupal-core"],
            "modules/contrib/{$name}": ["type:drupal-module"],
            "profiles/contrib/{$name}": ["type:drupal-profile"],
            "themes/contrib/{$name}": ["type:drupal-theme"],
            "drush/contrib/{$name}": ["type:drupal-drush"],
            "modules/custom/{$name}": ["type:drupal-custom-module"],
            "themes/custom/{$name}": ["type:drupal-custom-theme"]
        }
    },
    "autoload": {
        "psr-4": {
            "Drupal\\Core\\Composer\\": "core/lib/Drupal/Core/Composer"
        }
    },
    "scripts": {
        "pre-autoload-dump": "Drupal\\Core\\Composer\\Composer::preAutoloadDump",
        "post-autoload-dump": "Drupal\\Core\\Composer\\Composer::ensureHtaccess",
        "post-package-install": "Drupal\\Core\\Composer\\Composer::vendorTestCodeCleanup",
        "post-package-update": "Drupal\\Core\\Composer\\Composer::vendorTestCodeCleanup",
        "drupal-phpunit-upgrade-check": "Drupal\\Core\\Composer\\Composer::upgradePHPUnit",
        "drupal-phpunit-upgrade": "@composer update phpunit/phpunit phpspec/prophecy symfony/yaml --with-dependencies --no-progress",
        "phpcs": "phpcs --standard=core/phpcs.xml.dist --runtime-set installed_paths $($COMPOSER_BINARY config vendor-dir)/drupal/coder/coder_sniffer --",
        "phpcbf": "phpcbf --standard=core/phpcs.xml.dist --runtime-set installed_paths $($COMPOSER_BINARY config vendor-dir)/drupal/coder/coder_sniffer --"
    },
    "repositories": [
        {
            "type": "composer",
            "url": "https://packages.drupal.org/8"
        }
    ]
}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.