2

I'm managing my site dependencies via composer, most of the times works really well. Now I installed my site on a new server, using the exact same code-base as before (but with composer 1.8.0 instead of 1.7.x as before though). On running composer install I get the following error:

  • don't install drupal/core 8.6.4|remove drupal/drupal dev-master
  • remove drupal/drupal dev-master|remove drupal/core 8.6.4
  • Installation request for drupal/drupal dev-master -> satisfiable by drupal/drupal[dev-master].
  • Installation request for drupal/core 8.6.4 -> satisfiable by drupal/core[8.6.4].

Usually I can solve these sorts of errors but this time I'm having a hard time. What's the meaning of drupal/drupal dev-master, because usually you do not specify this anywhere directly?

  • Try to delete composer.lock first then run composer install – MiharbKH Dec 15 '18 at 15:17
  • Tried that, didn't work. – theuni Dec 15 '18 at 15:48
  • Did you figure out what was blocking your composer install? – hotwebmatter Dec 18 '18 at 1:22
2

I ran into the same issue. My issue was related to upgrading to a new Drupal core minor version (ex: 8.6 to 8.7). If that's not the case for you, then my steps may be unnecessary.

I was able to resolve it by removing the core directory of Drupal. Then run composer update drupal/core --with-dependencies. I believe the issue stems from the core/composer.lock file having conflicts with what you are trying to install.

1

Let me start off by saying that I've never encountered drupal/drupal dev-master before.

Based on my Composer experience, the nuclear option is to run composer install and upgrade everything all at once.

The more nuanced option is to use composer prohibits to figure out what's blocking an update.

This blog post from Jeff Geerling might help:

https://www.jeffgeerling.com/blog/2018/updating-drupalcore-composer-drupal-core-doesnt-update

From the article:

The thermonuclear option with Composer is to delete your vendor directory, delete your lock file, hand edit your composer.json with newer package versions, then basically start over from scratch. IMO, this is always a bad idea unless you feel safe upgrading all the things all the time (for some simple sites, this might not be the worst idea, but it still removes all the dependency management control you get when using Composer properly).

So it's better to find out exactly what dependencies are blocking you, and then explicitly require the packages with:

composer update drupal/core vendor/package --with-dependencies

Also:

https://www.jeffgeerling.com/blog/2017/composer-and-drupal-are-still-strange-bedfellows

  • 1
    totally forgot about composer prohibits. good hint thanks. I'll see what's causing the problems – theuni Dec 16 '18 at 10:55
  • Good luck! Let me know if it works for you! – hotwebmatter Dec 17 '18 at 12:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.