-3

I have a fresh D8.64+Bootstrap 3 installation, after enable multilingual modules, add languages and config language dection and content/menu translation, I placed the defualt language switcher to the primary sidebar. Then I translated some contents and menus to other languages. Strangely, when I switch languages, nothing happened, even no changes in the admin interface (only the default English)! I changed the theme, changed the language detection order, cleared cache...it was the same. I downloaded a dropdown language block, it even doesn't show up when I place it on the sidebar (but can show in bartik theme). I searched on internet for hours, but no luck. Could anybody have clue of solution?

Language switcher not working

  • What does sitename/sv return? – Jdrupal Dec 30 '18 at 22:08
  • I translated the site name, but when I switch the language, the site name remains the original one (English). – user59482 Dec 30 '18 at 23:08
  • Yes but did you see that the Swedish site works? – Jdrupal Dec 31 '18 at 7:47
  • No it does not. For instance, the Swedish homepage url is www.DOMAINNAME.com/sv, if i direct to this url, it still show default English for everything. If I edit this page to Swedish( title, body), then when i direct to English homepage, it also shows Swedish. Anyway I can only have one language. – user59482 Dec 31 '18 at 7:58
  • 1
    You have something wrong in your multilingual setup. Try to se Drupal.org they have a multilingual guide and see if you have done something wrong – Jdrupal Dec 31 '18 at 8:56
0

I finally sort this out:in the language detection and selection set the url first then others. Deleted the languages and reinstalled them. It suddenly worked. I even don't know why. Thank you @jdrupal very much for your patience and help!!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.