0

I am working with Drupal's Open social framework where in I copy socialblue theme so that i can do my modifications in the new theme. I followed the below steps, cleared cache, yet I am not able to see my new theme in admin/appearance section.

Steps I followed:

1) I duplicated the theme socialblue (html/profiles/contrib/social/themes/socialblue) to newtheme (html/profiles/contrib/social/themes/newtheme)

2) I did a search (socialblue) and replace (newtheme) inside of “newtheme” directory

3) I changed the names of the following files from “socialblue” to “newtheme"

newtheme.info.yml
newtheme.libraries.yml
newtheme.theme
config/install/newtheme.settings.yml

4) I created a /html/sites/default/services.yml file from default.services.yml and made the following changes

twig.config -> debug: true
twig.config -> auto_reload: true
twig.config -> cache: false

5) html/profiles/contrib/social/themes/newtheme$ yarn install

6) html/profiles/contrib/social/themes/newtheme$ sudo npm install -g gulp-cli

7) html/profiles/contrib/social/themes/newtheme$ gulp

I do not get any error. I made sure that my newtheme.info file has name newtheme. I also copied this new theme in html/themes/custom/newtheme still no luck. Am I missing something?

0

I solved it. Turns out it was because my base theme was mentioned as 'socialblue'. I changed it to 'socialbase' and it worked out. I don't know if a parent theme can have more than one child themes in drupal 8.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.