1

I'm trying to update a module with composer. This is the command (but it the same if I try to update another module):

composer update --with-dependencies drupal/geofield_map

This is the output of composer prohibits:

drupal/drupal  dev-master  requires  drupal/geofield_map (^2.10) 

I obtain these error when I try to update:

Problem 1
    - don't install drupal/core 8.6.5|remove drupal/drupal dev-master
    - remove drupal/drupal dev-master|remove drupal/core 8.6.5
    - don't install drupal/core 8.6.5|remove drupal/drupal dev-master
    - Installation request for drupal/drupal dev-master -> satisfiable by drupal/drupal[dev-master].
    - Installation request for drupal/core (locked at 8.6.5, required as ^8.6) -> satisfiable by drupal/core[8.6.5].

I'm not a "composer expert" and I'm not able to solve it.

Here is my composer.json

{
    "name": "drupal/drupal",
    "description": "Drupal is an open source content management platform powering millions of websites and applications.",
    "type": "project",
    "license": "GPL-2.0-or-later",
    "require": {
        "composer/installers": "^1.0.24",
        "wikimedia/composer-merge-plugin": "^1.4",
        "drupal/search_api_solr": "^2.0",
        "drupal/address": "~1.0",
        "mpdf/mpdf": "^7.0",
        "drupal/geofield_map": "^2.10",
        "drupal/console": "~1.0",
        "swiftmailer/swiftmailer": "5.4.5",
        "lullabot/amp": "^1.0.0",
        "drupal/csv_serialization": "^1.4",
        "drupal/core": "^8.6",
        "webflo/drupal-core-strict": "^8.6"
    },
    "minimum-stability": "dev",
    "prefer-stable": true,
    "config": {
        "preferred-install": "dist",
        "autoloader-suffix": "Drupal8"
    },
    "extra": {
        "_readme": [
            "By default Drupal loads the autoloader from ./vendor/autoload.php.",
            "To change the autoloader you can edit ./autoload.php.",
            "This file specifies the packages.drupal.org repository.",
            "You can read more about this composer repository at:",
            "https://www.drupal.org/node/2718229"
        ],
        "merge-plugin": {
            "include": [
                "core/composer.json"
            ],
            "recurse": true,
            "replace": false,
            "merge-extra": false
        },
        "installer-paths": {
            "core": ["type:drupal-core"],
            "modules/contrib/{$name}": ["type:drupal-module"],
            "profiles/contrib/{$name}": ["type:drupal-profile"],
            "themes/contrib/{$name}": ["type:drupal-theme"],
            "drush/contrib/{$name}": ["type:drupal-drush"],
            "modules/custom/{$name}": ["type:drupal-custom-module"],
            "themes/custom/{$name}": ["type:drupal-custom-theme"]
        }
    },
    "autoload": {
        "psr-4": {
            "Drupal\\Core\\Composer\\": "core/lib/Drupal/Core/Composer"
        }
    },
    "scripts": {
        "pre-autoload-dump": "Drupal\\Core\\Composer\\Composer::preAutoloadDump",
        "post-autoload-dump": "Drupal\\Core\\Composer\\Composer::ensureHtaccess",
        "post-package-install": "Drupal\\Core\\Composer\\Composer::vendorTestCodeCleanup",
        "post-package-update": "Drupal\\Core\\Composer\\Composer::vendorTestCodeCleanup",
        "drupal-phpunit-upgrade-check": "Drupal\\Core\\Composer\\Composer::upgradePHPUnit",
        "drupal-phpunit-upgrade": "@composer update phpunit/phpunit --with-dependencies --no-progress",
        "phpcs": "phpcs --standard=core/phpcs.xml.dist --runtime-set installed_paths $($COMPOSER_BINARY config vendor-dir)/drupal/coder/coder_sniffer --",
        "phpcbf": "phpcbf --standard=core/phpcs.xml.dist --runtime-set installed_paths $($COMPOSER_BINARY config vendor-dir)/drupal/coder/coder_sniffer --"
    },
    "repositories": [
        {
            "type": "composer",
            "url": "https://packages.drupal.org/8"
        }
    ]
}

[EDIT] If I try to replace "drupal/core": "^8.6" with "drupal/core": "8.6.5" I obtain:

 Problem 1
    - drupal/core 8.2.x-dev requires symfony/psr-http-message-bridge v0.2 -> satisfiable by symfony/psr-http-message-bridge[v0.2] but these conflict with your requirements or minimum-stability.
    - don't install drupal/core-render 8.2.0|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.2.0-beta1|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.2.0-beta2|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.2.0-beta3|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.2.0-rc1|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.2.0-rc2|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.2.1|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.2.2|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.2.3|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.2.4|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.2.5|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.2.6|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.2.7|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.2.8|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.2.x-dev|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.3.0|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.3.0-alpha1|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.3.0-beta1|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.3.0-rc1|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.3.0-rc2|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.3.1|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.3.2|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.3.3|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.3.4|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.3.5|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.3.6|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.3.7|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.3.8|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.3.9|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.3.x-dev|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.4.0|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.4.0-alpha1|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.4.0-beta1|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.4.0-rc1|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.4.0-rc2|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.4.1|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.4.2|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.4.3|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.4.4|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.4.5|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.4.6|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.4.7|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.4.8|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.4.x-dev|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.5.0|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.5.0-alpha1|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.5.0-beta1|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.5.0-rc1|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.5.1|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.5.2|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.5.3|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.5.4|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.5.5|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.5.6|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.5.7|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.5.8|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.5.x-dev|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.6.0|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.6.0-alpha1|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.6.0-beta1|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.6.0-beta2|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.6.0-rc1|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.6.1|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.6.2|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.6.3|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.6.4|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.6.5|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.6.x-dev|remove drupal/drupal dev-master
    - don't install drupal/core-render 8.7.x-dev|remove drupal/drupal dev-master
    - don't install drupal/core 8.3.x-dev|remove drupal/drupal dev-master
    - don't install drupal/core 8.4.x-dev|remove drupal/drupal dev-master
    - don't install drupal/core 8.5.x-dev|remove drupal/drupal dev-master
    - don't install drupal/core 8.6.5|remove drupal/drupal dev-master
    - don't install drupal/core 8.6.x-dev|remove drupal/drupal dev-master
    - don't install drupal/core 8.7.x-dev|remove drupal/drupal dev-master
    - remove drupal/drupal dev-master|remove drupal/core 8.6.5
    - don't install drupal/core 8.6.5|remove drupal/drupal dev-master
    - Installation request for drupal/drupal dev-master -> satisfiable by drupal/drupal[dev-master].
    - Installation request for drupal/core-render ^8.2 -> satisfiable by drupal/core[8.2.x-dev, 8.3.x-dev, 8.4.x-dev, 8.5.x-dev, 8.6.5, 8.6.x-dev, 8.7.x-dev], drupal/core-render[8.2.0, 8.2.0-beta1, 8.2.0-beta2, 8.2.0-beta3, 8.2.0-rc1, 8.2.0-rc2, 8.2.1, 8.2.2, 8.2.3, 8.2.4, 8.2.5, 8.2.6, 8.2.7, 8.2.8, 8.2.x-dev, 8.3.0, 8.3.0-alpha1, 8.3.0-beta1, 8.3.0-rc1, 8.3.0-rc2, 8.3.1, 8.3.2, 8.3.3, 8.3.4, 8.3.5, 8.3.6, 8.3.7, 8.3.8, 8.3.9, 8.3.x-dev, 8.4.0, 8.4.0-alpha1, 8.4.0-beta1, 8.4.0-rc1, 8.4.0-rc2, 8.4.1, 8.4.2, 8.4.3, 8.4.4, 8.4.5, 8.4.6, 8.4.7, 8.4.8, 8.4.x-dev, 8.5.0, 8.5.0-alpha1, 8.5.0-beta1, 8.5.0-rc1, 8.5.1, 8.5.2, 8.5.3, 8.5.4, 8.5.5, 8.5.6, 8.5.7, 8.5.8, 8.5.x-dev, 8.6.0, 8.6.0-alpha1, 8.6.0-beta1, 8.6.0-beta2, 8.6.0-rc1, 8.6.1, 8.6.2, 8.6.3, 8.6.4, 8.6.5, 8.6.x-dev, 8.7.x-dev].
  • which version of drupal you have (actual one)? – berramou Jan 6 at 18:51
  • I've 8.6.5, latest stable – arrubiu Jan 6 at 18:57
  • Ok, try with composer update --with-dependencies 'drupal/geofield_map:^2.23' – berramou Jan 6 at 18:59
  • I obtain: Problem 1 - don't install drupal/core 8.6.5|remove drupal/drupal dev-master - remove drupal/drupal dev-master|remove drupal/core 8.6.5 - don't install drupal/core 8.6.5|remove drupal/drupal dev-master - Installation request for drupal/drupal dev-master -> satisfiable by drupal/drupal[dev-master]. - Installation request for drupal/core (locked at 8.6.5, required as ^8.6) -> satisfiable by drupal/core[8.6.5]. – arrubiu Jan 6 at 19:01
  • Try with the steps of my answer on this question drupal.stackexchange.com/questions/267630/… – berramou Jan 6 at 19:53
1

I just had the same issue as you -- really bizarre. Instead of using composer update, I removed the module I was trying to update from my composer.json and ran composer require again instead for the newest version of the module (in your case this would be composer require drupal/geofield_map:^2.10).

I also had to remove the merge-plugin section of my composer.json (actually this may fix the issue without worrying about manually re-requiring the module).

  • removing merge-plugin section helped – frazras Feb 27 at 2:08
-2
  1. You can use the administrative interface: ==> admin/reports/updates/update
  2. Use drush
  3. Use the composer command : composer update ==> will update all your librairies
  • 1
    Doing a blanket composer update is ill advised unless specific versions of modules are listed in composer.json. I certainly wouldn't want 50 other modules to update when I am targeting one. – Kevin Jan 7 at 17:06
  • I already mentioned that composer updat will update all the modules – Hassan Gouzoul Jan 8 at 9:33
  • Updating everything when you only want to update one module is extremely risky. You take one change and turn it into hundreds. – Kevin Jan 8 at 16:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.