4

In the status report of my drupal website I got the message that I had to up Database 4 byte UTF-8 support. I updated all my tables and database like it's told here: https://www.drupal.org/node/2754539. I checked and all my tables and the database have utf8mb4 encoding and utf8mb4_general_ci collation.

I get the following warning:

Enabled, but database tables need conversion Please convert all database tables to utf8mb4 prior to enabling it in settings.php. See the documentation on adding 4 byte UTF-8 support for more information.

1

I fixed it by manual setting the drupal_all_databases_are_utf8mb4 variable to true. You can do this by using drush or setting it in the database and then clear all caches.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.