0

I am using hostmaster 7.x-3.171 and I am using the legacy SSL option (apache SSL - not apache HTTPS)

When i check the apache entry for the site in question at

/var/aegir/config/server_master/apache

it is missing the 443 entry and only has an entry for port 80 stuff.

I have double checked the site settings in aegir and SSL is enabled and a certificate is selected. I have tried to verify the site and no errors are presented. This seems to happen only if I try to verify a site that has SSL enabled. Maybe an update broke this somehow? I haven't done anything to mod the aegir set up that i can think of.

Has anyone had a similar problem recently in aegir? Any help would be appreciated!

1

Is there any particular reason why you're using the legacy option, and not Aegir HTTPS?

The legacy option is no longer supported so my recommendation would be to follow the documentation to switch.

  • 1
    I worked awhile to try and switch to apache HTTPS but it didn't seem to work like the legacy self signed cert. In legacy, I would self-sign and then replace the crt files and add a chain file (openssl_chain.crt) and then aegir would pick it up on site verify and use it. Apache HTTPS didn't seem to detect the chain file. That being said, all of my sites now use simple SSL certs (no EVs) so my plan is to try and switch everything to Lets Encrypt later. However, if there is documentation on how I would use Apache HTTPS with EV certificates, I would be very interested to read it. Thanks for help! – timftw Jan 10 at 16:20
  • Actually, nobody's added that feature yet as most of us have been happy with the LE certificates, even thought they're not EV. The issue for this is drupal.org/project/hosting_https/issues/2936037 so any help (patches or funding) would be appreciated! – colan Jan 11 at 17:47
0

This should now be solved in provision 7.x-3.172, updating just that component and verifying a site should be enough to resolve this.

However +1 for switching to Aegir_https as @colan suggests.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.