0

I'm developing my first Drupal 8 Webforms application. It had three pages to start with and I had managed to get it to do what I wanted it to. I have also developed a WebformHandler to go with it.

I needed to add an extra page between the old 1st and 2nd page. I created this using the "build" tab and it was created in 4th position in the list of pages, so I dragged it up to 2nd position and did "Save Elements".

But then, when I used the "View" tab to try out the form, the dialogue started at the 3rd page (the old 2nd page). I have now deleted the new 2nd page and appear to have the same old configuration that worked, but using the "View" tab still ignores the first page.

I have flushed all the caches; I have looked in the database for anything obvious (but not found anything); I have looked at the YAML files in the module I created for the Webform; I have even rebooted the server.

I have tried to scan the entire Drupal file tree looking for files that have been modified in the last couple of hours (since the webform last started correctly), but I haven't managed to find anything, except the WebformHandler, but that isn't called before the initial page is shown.

Using a different browser (Safari instead of Chrome) produces the same result, so I guess the problem is on the server and not the client.

Somewhere, something is holding information about my webform: could anyone help me to locate it?

  • most likely a indentation in the source yml enable webform devel and view the source see if any thing is miss aligned ? – Taggart Jensen Jan 10 at 1:36
  • 1
    If you can't figure this out, please export the webform config and create a GIST (gist.github.com) so that we can look at the source code. – jrockowitz Jan 10 at 8:56
  • Thanks for your comments. I have found the problem. The element editor in Webforms includes an "Access" tab. For the pages in question, I had removed all permissions for all roles under this tab, which included the "administer" role I work under, so – obviously :-) – I had no access to those pages. – Stephen Winnall Jan 10 at 22:12
  • @StephenWinnall Could you post this as an answer for the benefit of future visitors? – Alfred Armstrong Jan 11 at 16:41
0

I was looking in the wrong places...

The element editor in Webforms includes an Access tab. For the pages that were not being shown I had removed all the permissions, which included the permissions of ‘Administrator’, the user I was logged in as. So – obviously – those pages were not shown.

Duuhh.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.