Customer bought a theme that has a Commerce plugin installed with sample data. Anxious to get it running and try out the new configuration system, I did what I do prior to Drupal 8.6: I committed everything but sensitive info into git, cloned to my local, and dumped the MySQL database. After getting the index page, every page returned a 500 error like the following ones.

Attempt to create a field commerce_remote_id that does not exist on entity type user

The entity type does not exist. in Drupal\Core\Entity\EntityTypeManager::getDefinition()

Copying all files from modules/commerce to modules/profile should get me past these errors.

drush updb returns no updates needed. drush cr offers no relief.

OK, I wanted to start using the new configuration system. On the customer site, I ran drush cex and committed to git.

On my local, after git pull, drush cim returns:

This import is empty and if applied would delete all of your configuration, so has been rejected.

It appears that Drush will not import, but I prefer to use drush site:install with an existing configuration.

Can Drush 9.5.2 install a new site onto itself using the existing settings.php file?

I would like to synchronize configuration files to remove that as a factor to resolve my local site being hosed.

I read in another tutorial that the UUID must be copied over because the UUIDs in system.site.yml must match. I can confirm they match by running drush config.get system.site.

  • Is it configured to point at the right config directory so Drush knows where to look for it?
    – Kevin
    Jan 12, 2019 at 15:30

1 Answer 1


Do double check the directory where the config files are located. The directory is set in settings.php like:

$config_directories['sync'] = 'sites/default/files/[...]/sync';

I had the same issue but moving the config directory to the correct place solved it.

  • 1
    do the export to that folder first, then cim works properly drush cex sync
    – Solomon
    Feb 21, 2020 at 16:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.