0

I am trying to update Drupal Core 8.6.3 to 8.6.5 (which is the latest Core update at time of writing this).

Using this CLI Composer command:

composer update drupal/core --with-dependencies

completes the whole process without errors.

But after clearing Drupal's cache and checking Status Report, it still shows the previous version (8.6.3).

I'm assuming a dependency may be blocking the Core update.

To test this I ran this CLI Composer command:

composer prohibits

and received this error:

[Symfony\Component\Console\Exception\RuntimeException]  
  Not enough arguments (missing: "package").

After searching a few forums I could not find a definite explanation of that error's meaning or how to address it.

UPDATE - As per my answer below, I found a solution which was:

I noticed in a few threads that this inclusion kept being referred to as a potential Core update issue:

webflo/drupal-core-require-dev

So I checked my composer.json require list and it was there, specifying the earlier Core version:

    "require-dev": {
    "webflo/drupal-core-require-dev": "8.6.3"
},

To correct this, I ran this CLI Composer Command:

composer update drupal/core webflo/drupal-core-require-dev --with-dependencies

After clearing cache (drush cr) I checked back on my composer.json and the require had changed to:

    "require-dev": {
    "webflo/drupal-core-require-dev": "^8.6.0"
},

This then triggered a Status Report Warning that 2 Tables required update. To fix this I ran this CLI Command:

drush updatedb

I then successfully run this CLI Composer command:

composer update drupal/core --with-dependencies

After another cache clear, I checked Drupal's Status Report which showed the update to Core had worked. I was happy with this so (as I was in maintanenace mode during this time) I then used this CLI command to turn off maintenance mode:

drush sset system.maintenance_mode 0

And all is well and working correctly.

  • Are you certain it didn’t update? – Kevin Jan 16 at 2:28
  • composer and other console apps usually have composer help <command> as a way to get inline help. This outputs the usage of prohibit as prohibits [options] [--] <package> <constraint>. – mradcliffe Jan 16 at 2:29
1

I found some other threads that highlighted webflo/drupal-core-require-dev as being an issue, In CLI I ran

composer show

This showed me that webflo/drupal-core-require-dev was set to 8.6.3

So I ran update in CLI:

composer update drupal/core webflo/drupal-core-require-dev --with-dependencies

This updated the require version to 8.6.5. Upon checking Drupal Status Report it also triggered a warning requiring Database updates, so I ran:

drush updatedb

and approved"yes" to the 2 updates.

This removed the Database error from Status Report and I then ran the core update CLI again:

composer update drupal/core --with-dependencies

This time it worked, so I cleared cache and turned off maintenance mode:

drush cr
drush sset system.maintenance_mode 0

and the Status Report is now clear of errors and warnings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.