0

Please don't consider this as a duplicate post. I have tried all the solutions that worked for others, but still struggling to fix the problem (all users including admin taken to 403 page). This is a Windows server running Drupal 7.

Things I have tried -

  • No base_url value given
  • No cookie_domain value given
  • Session table truncated
  • Cache tables truncated
  • No file permission differences
  • Tried Reset password email but the link takes to 403 page
  • Deleted browser cache

Please let me know if anyone has experience with a similar issue or what else I could try.

This is what I can see in watchdog table. enter image description here

Thanks

2

I finally figured it out!

We are enforcing secure flag on our cookie and therefore had to disable the corresponding rewrite rule from IIS, as we didn't have a SSL certificate in new server.

1

Check the user table in the DB. sometimes when importing DBs it starts auto-numbering from 1, so you don't have a user with the id of 0, which Drupal uses for its anonymous user.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.