1

Situation: Drupal 8.6.9 running DrupalVM with Ubuntu 16.04, Apache 2.4.18, Php 7.1.26 with default settings except for the location of the drupal site.

I am trying to do a migration of a Drupal 7 multilingual site to Drupal 8.

Plan is to setup the Drupal 8 site with as much settings and modules as possible so I can alter the content during the migration such as migrating a D7-field to a different D8-field.

I wiped the default DrupalVM drupal site so I can start from scratch. So far I have done a drush site-install with standard profile, enabled some contrib modules that are also in the D7 site (pathauto, search404, etc.) and manually set the necessary settings. One of them is adding the 'field_image' to the 'Basic Page' content type. I've exported the settings (Config Synchronization) to the config sync directory.

To start from scratch I run a script that does:

drush si standard
drush en <various modules installed with composer>
drush cset "system.site" uuid <uuid set in system.site.yml>

When I stop here and manually create several page nodes through the UI I can successfully add images and the thumbnails are created accordingly.

When I go on and import the config settings with:

drush cim sync --partial

Everything is imported succesfully and everything looks fine.

However, when I add the same page nodes through the UI the images are uploaded successfully but the image styles are not created. The 'styles' directory stays empty and the Apache logs show:

[Sun Feb 10 20:03:18.426565 2019] [proxy_fcgi:error] 
[pid 9432:tid 140423712450304] 
(32)Broken pipe: [client 192.168.88.1:59863] 
AH01075: Error dispatching request to : 
(passing brigade to output filters), referer: http://www.drupalvm.test/node/add/page

(error broken in several lines to avoid scrolling)

No errors in php-fpm logs.

The error seems to point to a bug in Apache 2.4/mod_fcgi, but that has been fixed in 2016.

Also, because the problem occurs after reading in the config settings, not before, I suspect the problem is either related to the config settings or to Drupal itself.

Does anyone have any idea what to check to solve this problem? I'm on this for days now with no success.

2

I went through adding all the files one by one and finally found the problem:

image.settings.yml contained:

suppress_itok_output: true

Once it was changed to false the problem disappeared.

  • hmm, that's already set to false in my d8 install (8.6.9) but I'm still having this problem – Dan Mantyla Feb 20 at 19:50
  • Maybe you have a migration that sets it to true again? Or you only read in configuration? – hepabolu Feb 22 at 1:34
  • thanks for the response. I think the problem is just in how my Drupal site is setup. Copying everything in d7/sites/default/files/styles to d8/sites/default/files/styles solved it – Dan Mantyla Feb 22 at 14:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.