0

My research
I have browsed some of the other similar questions asked regarding this but the fixes do not work for me so I figured I'd ask a new question in the hopes that I can help myself and hopefully others that have the same issue. I have also checked the drupal help forums which again does not fix my issue.

What I want to happen
This is using Drupal 7. I want to make it so that when creating a news article, I can upload files that can be downloaded when people view the page.

What happens when I try to do this
I have added the field successfully and when creating the page, I can upload the file and it shows in the preview. However, when I save the page, although the file shows as uploaded in the 'edit' side, it does not show on the public page.

What I've tried
Additionally, when checking in the files through FTP, the files gets uploaded to the sites/default/files/ directory. I have checked, double checked and tripled checked the permissions which I even set to 777 briefly so permissions doesn't seem to be the issue here.

I have tried commenting out some lines in the sites/default/files/.htaccess file which is one fix I found but unfortunately didn't work for me.

I have checked user permissions which, again, isn't the issue as I'm an admin with every permission checked.

I have also copied the exact settings from another website where this feature is working in case I missed something very simple but this didn't work either unfortunately. The file upload field is set to display and I believe that it's set up appropriately although it is possible I'm missing something extremely simple.

I'm more than happy to update my question with further information if anyone needs any more to help me out. I'm completely baffled on this one so any help would be greatly appreciated.

  • Did you check "Manage Display" page under your Content type settings? (admin/structure/types/manage/article/display) The Field may be hidden or there is a problem with its display settings. Have you tried visiting the file path directly by typing it in your browser location? Or linking the file through HTML inside Body area? – prkos Feb 14 at 15:59
  • I've tried that yes, I also created a new content type and replicated the settings exactly. The new content type displays file attachments but the other doesn't which is very bizarre. – Ember Feb 14 at 16:19
0

So after a lot of digging, I realised that this issue was due to the Panels module.

I had only added the field the usual way you would; through the content type when it turns out you need to configure it through the Panels view (which I was completely unaware of until today).

You would think that configuring it though the content type would be enough but evidently not.

Nonetheless, hopefully my question and answer will come in useful to someone one day who encounters a similar issue to mine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.