0

For some reason system.site, system.performance and system.date config values have been deleted from our site.

I have the original configuration files, but when attempting to import those using drush cim, Drush complains about the site UUID mismatch.

The import failed due to the following reasons:                 
Site UUID in source storage does not match the target storage. 

I assume this is because UUID is missing entirely. If I run drush cget system.site, I get the following error:

[error]  Config system.site does not exist 

Attempting to set the UUID with drush config-set "system.site" uuid "my site id" also fails with:

[error]  Config system.site does not exist 

So now I'm in a bit of conundrum.

Any suggestions on how to restore the system.site configuration?

1

I solved it with Drush.

To get around the UUID mismatch I uncommented the UUID field in system.site.yml and ran drush cim. After that I specifically set the UUID by running drush cset "system.site" uuid "my site id".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.