0

I'm trying to setup Facebook login integration for my Drupal site using the HybridAuth Social login module. It is not working with "Use Strict Mode for Redirect URIs" enabled and I am failing to disable it. I think it's an issue of the redirect_uri setting.

I tried it with siteurl/hybridauth/endpoint?hauth_done=Facebook and siteurl/hybridauth/endpoint?hauth.done=Facebook but it's not working.

Here is the error:

THERE WAS AN ERROR PROCESSING YOUR REQUEST.

And in my Drupal log:

Exception: Facebook Graph returned an error: URL can not be loaded: The domain of this URL is not present in the domains of the app. To be able to load this URL, add all your domain's domains and subdomains in the Appdomain box in your app settings. in Hybrid_Auth :: initialize ()

What do I need to do to successfully enable Facebook login integration for my site?

  • 1
    I think the error message in your Drupal log is already saying it all: The domain of this URL is not present in the domains of the app. On Facebook add the domain to your app and it'll probably work. You already created an app on Facebook did you? – leymannx Feb 26 at 13:18
  • You must have entered the wrong details when you created your Facebook app. Go to developers.facebook.com/apps and check your app settings and configured domain names. – Malek Massoudi Feb 27 at 11:44
  • 3
    I'm voting to close this question as off-topic because it is about the general setup of a third-party service API account and not related to Drupal. Please read the docs of the third-party service provider. – Mario Steinitz Mar 6 at 20:57
  • @leymannx i have crested an app and the domain also added there. but strangely this error occurring. – Iqbal Mar 8 at 4:57
  • @MarioSteinitz it seems everything added in fb app is fine. but it is not working – Iqbal Mar 8 at 4:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.