0

I enabled theme debug on my drupal 7 installation using drush vset theme_debug 1, But Now I can't disable theme debug using drush vset theme_debug 0, What the wrong, Is there any wrong or mistakes in the drush command above?

I also tried to comment out $conf['theme_debug'] = TRUE; in the settings.php and then replaced with $conf['theme_debug'] = FALSE; but none works.

Any help and suggestions on this issue?

Thanks

3
  • Do you have file local.setting.php?
    – Jonh
    Feb 28, 2019 at 8:50
  • Hi @Jonh, Thanks for quick replying. I don't have local.setting.php. I can see there is a file called default.setting.php & setting.php in sites/default directory.
    – Abu Zafor
    Feb 28, 2019 at 9:32
  • try to execute drush vset theme_debug 0 with --debug to see if there is any errors!
    – berramou
    Feb 28, 2019 at 9:54

1 Answer 1

1

If using drush vset theme_debug 0 doesn't work. Try disabling the theme debugging on your settings.php file, adding the below line of code:

$conf['theme_debug'] = FALSE;

Don't forget clear the cache.

3
  • Thanks for your suggestion, I actually did that but NO LUCK. You can check my question description where I mentioned this. However, I may messed up everything, getting a lot of error log message.
    – Abu Zafor
    Feb 28, 2019 at 17:38
  • 2
    Hay @heilop, After restoring a backup, drush vset theme_debug 0 started working again. Thanks for your answer. You suggestion also working now.
    – Abu Zafor
    Feb 28, 2019 at 22:05
  • @AbuZafor, You're welcome!
    – heilop
    Apr 9, 2019 at 22:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.