4

Sometimes, Drupal has the annoying habit to automatically add HTML to the content's source, generally <br/> and <p>, even when the text format is set to "Full HTML".

This is really annoying and I can't find any way to prevent that. Any idea ?

2 Answers 2

7

Ok, I think I've found the answer:

This is a "feature" of the Full HTML mode.

Full HTML:

  • Web page addresses and e-mail addresses turn into links automatically.
  • Lines and paragraphs are automatically recognized. The
    line break,

    paragraph and

    close paragraph tags are inserted automatically. If paragraphs are not recognized simply add a couple blank lines.

You can disable it in You are here Administration » Configuration » Content authoring » Text formats by unchecking Convert line breaks into HTML (i.e. <br> and <p>).

Source: http://drupal.org/node/503754

1
  • 1
    My, too slow ...
    – Countzero
    Apr 6, 2012 at 8:57
2

It depends on the configuration of the filters the input format uses.

You can disable the tags you're talking about on the page : http://yoursite/admin/config/content/formats/full_html.

Just uncheck Convert line breaks into HTML (i.e. <br> and <p>).

Not the answer you're looking for? Browse other questions tagged or ask your own question.