0

I installed Drupal on my localhost (LAMP Stack), and I am trying to install modules, but I get the following error.

enter image description here

I tried changing the permissions of the folder, but still it is not working. It is showing same error from both the methods of installation.

  • 1
    Did you check the permission and owner of sites folder, can you add the result of ls ali . of the ligne end with sites ? – berramou Mar 5 '19 at 11:16
  • drwxrwxrwx 3 akshay akshay 4096 Dec 5 17:28 sites @berramou – Akshay Rathod Mar 5 '19 at 11:20
  • 3
    This isn't related to file permissions. The warning is telling you that the FTP connection you're using is not secure, and that your username and password will be sent plaintext with the request. To fix properly, stop using this interface, and use Composer (or possibly Drush for D7) to manage your modules. – Clive Mar 5 '19 at 11:21
2

It's not an error, but a warning reminding you that you aren't using an encrypted connection, and that the credentials you are using (username and password) could be read from somebody who can intercept the data exchanged between your computer and the server. If you look at the protocol used for the page, you will notice it's http://, not https://.
It's not an error caused from the file/directory permissions.

If you don't have a SSL certificate, just enter username and password that are accepted from the FTP server, and install the modules. The warning is just suggesting that using a secure communication would be preferable.

You could also avoid Drupal prompts for FTP/SSH credentials by setting the owner of the temporary:// directory (and its subdirectories) to the owner of the sites/default directory (which, in your case, I take is akshay).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.