0

I'm using Acquia Search for searching within certain content types (articles, posts, etc). It seems to work for certain keywords but not others. For example, if I search: "Apple TV", I'm expecting the article title: "Spectrum Launches on Apple TV, Offers Apple TV 4K to Customers" to show up (which it does). However, if I search for "4K" the search API brings back "no results".

I reviewed our Acquia connector set up, re-indexed all content and tried with no success. The weird thing is, if I search "4K to customers" it shows the correct article with "4K" also being highlighted (in search results). Does any one have any idea why this would happen? It seems that our config is set up to read basically every field in each content type included and it does seem that this article is indexed. Does anyone have an idea to point me in the right direction?

I'm using the latest versions of Acquia connector, acquia search, search API and Drupal 8.

  • It's pretty common for <= 3 characters to not be searchable - this should be configurable. I'd take a look at that first. – Patrick Ryan Mar 5 at 23:45
  • @PatrickRyan Thank you so much! I really appreciate it! This is my first go around with Solr Search - I can't believe I didn't think to check the default configs. – Daniel Mar 6 at 17:58
0

Set your Minimum keyword length to 2 in the filter criteria of your search-view

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.