0

On a standard multilingual Drupal installation (Drupal 8.6.10), when editing existing content or creating new content the option language neutral isn't available; only the enabled languages and some other options are shown.

available language options

How do I select Language neutral?

  • Have you tried the "Not specified" option ? – GiorgosK Mar 10 at 22:39
  • I tried now again and this seems to work. But where's "language neutral" gone? According to this answer drupal.stackexchange.com/questions/197521/… "not specified" semantically has another meaning than "language neutral". – Madam Adam Mar 10 at 23:34
1

In Drupal 8 LANGUAGE_NONE (neutral) has changed to LANGUAGE_NOT_SPECIFIED, LANGUAGE_NOT_APPLICABLE and LANGUAGE_MULTIPLE.

I usually use LANGUAGE_NOT_SPECIFIED where I used to use LANGUAGE_NONE in Drupal 7.

Berdir mentions that all those new options makes no difference to how content is displayed, but they let you treat differently to content on your site if you'd wanted to in views, custom code, ...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.