0

I'm trying to upgrade from Drupal 8.5 to 8.6 and I keep getting this error:

[info] Undefined index: scheduled_transition_state BaseFieldOverride.php:167 TypeError: Argument 2 passed to Drupal\Core\Entity\ContentEntityStorageBase::onFieldDefinitionUpdate() must implement interface Drupal\Core\Field\FieldDefinitionInterface, null given, called in /var/www/bwd/docroot/core/lib/Drupal/Core/Field/Entity/BaseFieldOverride.php on line 207 in /var/www/bwd/docroot/core/lib/Drupal/Core/Entity/ContentEntityStorageBase.php on line 441 #0 /var/www/bwd/docroot/core/lib/Drupal/Core/Field/Entity/BaseFieldOverride.php(207): Drupal\Core\Entity\ContentEntityStorageBase->onFieldDefinitionUpdate(Object(Drupal\Core\Field\Entity\BaseFieldOverride), NULL)

I've got a custom profile and lots of configuration to import, but it all works fine on 8.5. I'm using blt setup -n to install Drupal. I've got BLT and Lightning and I suspect one of them is causing the problem, but I can't remove them from my project.

Any advice?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.