0

When i try to run composer update it results to the following problem:

Your requirements could not be resolved to an installable set of packages.

 Problem 1
    - don't install drupal/core 8.6.0|remove drupal/drupal dev-master
    - don't install drupal/core 8.6.0-alpha1|remove drupal/drupal dev-master
    - don't install drupal/core 8.6.0-beta1|remove drupal/drupal dev-master
    - don't install drupal/core 8.6.0-beta2|remove drupal/drupal dev-master
    - don't install drupal/core 8.6.0-rc1|remove drupal/drupal dev-master
    - don't install drupal/core 8.6.1|remove drupal/drupal dev-master
    - don't install drupal/core 8.6.10|remove drupal/drupal dev-master
    - don't install drupal/core 8.6.2|remove drupal/drupal dev-master
    - don't install drupal/core 8.6.3|remove drupal/drupal dev-master
    - don't install drupal/core 8.6.4|remove drupal/drupal dev-master
    - don't install drupal/core 8.6.5|remove drupal/drupal dev-master
    - don't install drupal/core 8.6.6|remove drupal/drupal dev-master
    - don't install drupal/core 8.6.7|remove drupal/drupal dev-master
    - don't install drupal/core 8.6.8|remove drupal/drupal dev-master
    - don't install drupal/core 8.6.9|remove drupal/drupal dev-master
    - don't install drupal/core 8.6.x-dev|remove drupal/drupal dev-master
    - don't install drupal/core 8.7.x-dev|remove drupal/drupal dev-master
    - don't install drupal/core 8.8.x-dev|remove drupal/drupal dev-master
    - remove drupal/drupal dev-master|remove drupal/core 8.6.10
    - Installation request for drupal/drupal dev-master -> satisfiable by drupal/drupal[dev-master].
    - Installation request for drupal/core ~8.6 -> satisfiable by drupal/core[8.6.0, 8.6.0-alpha1, 8.6.0-beta1, 8.6.0-beta2, 8.6.0-rc1, 8.6.1, 8.6.10, 8.6.2, 8.6.3, 8.6.4, 8.6.5, 8.6.6, 8.6.7, 8.6.8, 8.6.9, 8.6.x-dev, 8.7.x-dev, 8.8.x-dev].

I have tried many suggestions to try and resolve this problem but no luck. I don't know where my problem is. Also when i try to update on another computer or server it doesn't give me this problem. I don't know what i am missing.

So if anyone can help me out with this it would be much appreciated

This is my composer file:

{
    "name": "drupal/drupal",
    "description": "Drupal is an open source content management platform powering millions of websites and applications.",
    "type": "project",
    "license": "GPL-2.0+",
    "require": {
        "drupal/core": "^8.6.0",
        "composer/installers": "^1.0.24",
        "wikimedia/composer-merge-plugin": "~1.4",
        "drupal/console": "~1.0",
        "drupal/metatag": "^1.2",
        "drupal/pathauto": "^1.0",
        "drupal/google_analytics": "^2.1",
        "drupal/country": "1.x-dev",
        "drupal/webform": "5.x-dev",
        "drupal/geolocation": "^1.10",
        "drupal/twig_tweak": "^1.8",
        "solarium/solarium": "^3.8",
        "drupal/redirect": "^1.0@beta",
        "drupal/search_api_solr": "^1.2",
        "tinify/tinify": "1.4.*",
        "drupal/tinypng": "^1.0@alpha",
        "drupal/IMCE": "^1.6",
        "drupal/editor_advanced_link": "^1.4",
        "drupal/captcha": "^1.0@beta",
        "drupal/recaptcha": "^2.2",
        "drupal/swiftmailer": "^1.0@beta",
        "drupal/xmlsitemap": "1.x-dev"
    },
    "minimum-stability": "dev",
    "prefer-stable": true,
    "config": {
        "preferred-install": "dist",
        "autoloader-suffix": "Drupal8"
    },
    "extra": {
        "_readme": [
            "By default Drupal loads the autoloader from ./vendor/autoload.php.",
            "To change the autoloader you can edit ./autoload.php.",
            "This file specifies the packages.drupal.org repository.",
            "You can read more about this composer repository at:",
            "https://www.drupal.org/node/2718229"
        ],
        "merge-plugin": {
            "include": [
                "core/composer.json"
            ],
            "recurse": false,
            "replace": false,
            "merge-extra": false
        },
        "installer-paths": {
            "core": ["type:drupal-core"],
            "modules/contrib/{$name}": ["type:drupal-module"],
            "profiles/contrib/{$name}": ["type:drupal-profile"],
            "themes/contrib/{$name}": ["type:drupal-theme"],
            "drush/contrib/{$name}": ["type:drupal-drush"],
            "modules/custom/{$name}": ["type:drupal-custom-module"],
            "themes/custom/{$name}": ["type:drupal-custom-theme"]
        }
    },
    "autoload": {
        "psr-4": {
            "Drupal\\Core\\Composer\\": "core/lib/Drupal/Core/Composer"
        }
    },
    "scripts": {
        "pre-autoload-dump": "Drupal\\Core\\Composer\\Composer::preAutoloadDump",
        "post-autoload-dump": [
          "Drupal\\Core\\Composer\\Composer::ensureHtaccess"
        ],
        "post-package-install": "Drupal\\Core\\Composer\\Composer::vendorTestCodeCleanup",
        "post-package-update": "Drupal\\Core\\Composer\\Composer::vendorTestCodeCleanup"
    },
    "repositories": [
        {
            "type": "composer",
            "url": "https://packages.drupal.org/8"
        }
    ]
}
  • What suggestions exactly did you try so far which didn't work? – leymannx Mar 13 at 12:04
  • composer clearcache before update? composer update --with-dependencies? rm -rf vendor/ before update? rm composer.lock before update? – leymannx Mar 13 at 12:15
  • What is the Drupal version specified on your composer.json? Is it dev-master? Try to replace it for something like this "drupal/core": "^8.6.0". – Lesley Fernandes Moreira Mar 13 at 13:24
  • Hi @David Ricardo Fernandez! Welcome on drupal.stackexchange.com ;-) Can you please add the require / require-dev-part of your composer.json, then we can help you better. And we can check if something is wrong there... – btemperli Mar 13 at 20:00
  • @LesleyFernandesMoreira, i don't use dev-master anywhere in my composer file. – RockNova Mar 18 at 15:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.