What's wrong with Contribute 8.x-5.0-beta3 module?

After 8.6.10 update I have a problem with Contribute module. First it's marked as outdated/not supported but on some sites I can not remove it fully as it lefts something in the db.

So finally I get the errors like

"The following module is missing from the file system: block_user bootstrap.inc:276"

even after the

drush pm:uninstall

It's a composer managed install.

2 Answers 2


Always you have to first uninstall the module, then remove the codebase from filesystem.

Composer have nothing to do with installing or uninstalling of modules in drupal. Composer is responsible for downloading the needed files, or removing if not longer in use.

If you first remove the files from the filesystem, you cannot uninstall it properly, because drupal not knows what to do. Therefore you see such errors about missing things.

What can you do now to get rid of this error if such happen:

  1. Go one step back & put missing files back to filesystem.

    • If you use git, checkout your last composer.lock before this error, than type composer install to get the old module files back.
    • Or use your backup or your ftp-program to bring the module files back.
  2. Now you can uninstall the module as you like, perhaps using the gui or with drush (typing drush pmu modulename). This step is important, because it removes all things installed by this module. If you skip this, you will get such errors.

  3. Now delete unwanted module files again:

    • checkout your newest state of composer.lock (without that module)
    • and type composer install and composer will remove the unwanted files
  4. Don't forget to clear the cache. (drush cr)

  • Did it twice .. works for most sites but not for one which keeps throwing error no matter what I do. I can install and uninstall and remove a number of times. But no luck.
    – Paul Paku
    Mar 13, 2019 at 22:23
  • Is there any reason for you to use old core version 8.6.1 instead of the actual one (8.6.11)? If no other helps, you can try to get rid of the outdated module data in database by the commands described in this post: [link] (drupal.stackexchange.com/questions/235487/…) Mar 14, 2019 at 6:21
  • Sorry it was 8.6.10, just my mistype.. But 8.6.11 update solved the issue.
    – Paul Paku
    Mar 14, 2019 at 9:02
  • Then you should mark the answer form Paul Paku as accepted to show all that his answer worked for you and your issue is solved. Mar 14, 2019 at 9:09

Drupal 8.6.11 update solved the problem. After the update the Contribute module was removed as it should be.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.