0

Can not update drupal/core to 8.6.11

composer prohibits drupal/core:8.6.11

shows

webflo/drupal-core-require-dev  8.6.10  requires  drupal/core (8.6.10)

How can I solve it ??

2

The trick is, that drupal/core and webflo/drupal-core-require-dev always have to point to the very same version.

If you use composer update composer will look for this and pull the needed actual versions alone.

There are some articles recommending not to do so, but instead to update in minor parts and specify a concrete packet for better testing and reverting possibilities if something goes wrong. This means typing:

composer update drupal/core --with-dependencies

This may be true, but I often run in such errors with dependencies then I have to solve myself. You have now to specify both packets in the same command, then it will work too:

composer update drupal/core webflo/drupal-core-require-dev --with-dependencies

My private conclusion:

  • If I have time to go the suggested way and solve such dependencies, than I will specify the single packet to update.
  • If it makes problems and I have an actual backup of my codebase and my database (as you should alwas have before updating anything!) and have not so much time, I simple type composer update and mostly all will work out of the box at the first try.
1

Simple

composer update 

did the trick by have no idea why

composer update drupal/core --with-dependencies

did not ...

final result is:

  - Updating drupal/core (8.6.10 => 8.6.11): Downloading (100%)
  - Updating webflo/drupal-core-require-dev (8.6.10 => 8.6.11)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.