0

I've followed this guide to setup settings.local.php: https://www.drupal.org/node/2598914

And in my custom subtheme I have a stylesheet style.css which is working correctly. However when I look in the network tab in Chromium I see that the file is being renamed and loaded as the following instead of style.css

css_vUzTZgnz_vbCKVrMpGH7w6mCDpJcmKbwfvLonjhF6Yo.nbvVRORIA_VOZ9jlIN0xvyy_2wDJZdAeRBMnmfGNre0.css?poey84

Is there a way to stop this renaming using settings.local.php during development? I've tried turning off css aggregation through the GUI but I believe the changes in settings.local.php override this anyway?

Cheers

  • 2
    $config['system.performance']['css']['preprocess'] = FALSE; with this in your settings.local.php you should be OK. Check in the settings.php perhaps after the inclusion of settings.local.php, check in the admin/config/development/performance under performance optimization and report what you see. Perhaps there is a module that forces this setting? – GiorgosK Mar 15 at 15:34
  • What Giorgos says. Yes, looks like you have advagg enabled. Disable it during development. – leymannx Mar 15 at 18:53
  • Thank, advagg was the problem. I had disabled it but it was still renaming the files. Fully uninstalling the advagg module with drupal console was the solution. – hjalpmig Mar 18 at 15:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.